summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-26 03:43:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-26 04:09:30 +0200
commitf305ac26762d6ae7352694a3e3cb76a16ac1181b (patch)
tree1aa79fbe8cd458189e57de592c45e755dead25d4 /dev-python/gast/gast-0.5.5.ebuild
parentdev-python/enzyme: Bump to 0.5.2 (diff)
downloadgentoo-f305ac26762d6ae7352694a3e3cb76a16ac1181b.tar.gz
gentoo-f305ac26762d6ae7352694a3e3cb76a16ac1181b.tar.bz2
gentoo-f305ac26762d6ae7352694a3e3cb76a16ac1181b.zip
dev-python/gast: Bump to 0.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gast/gast-0.5.5.ebuild')
-rw-r--r--dev-python/gast/gast-0.5.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/gast/gast-0.5.5.ebuild b/dev-python/gast/gast-0.5.5.ebuild
new file mode 100644
index 000000000000..4747a4e751f1
--- /dev/null
+++ b/dev-python/gast/gast-0.5.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A generic AST to represent Python2 and Python3's Abstract Syntax Tree (AST)"
+HOMEPAGE="
+ https://github.com/serge-sans-paille/gast/
+ https://pypi.org/project/gast/
+"
+
+LICENSE="BSD PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+distutils_enable_tests unittest