summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-03 11:12:29 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-03 11:13:40 -0800
commit4a8fad9d2ef52ec19dd3e96f65b5dbe91b03134e (patch)
tree85b80f0cb8048934296b9ae2b7a61682959f74a2 /dev-python/fields
parentdev-python/characteristic: Add RESTRICT="!test? ( test )" (diff)
downloadgentoo-4a8fad9d2ef52ec19dd3e96f65b5dbe91b03134e.tar.gz
gentoo-4a8fad9d2ef52ec19dd3e96f65b5dbe91b03134e.tar.bz2
gentoo-4a8fad9d2ef52ec19dd3e96f65b5dbe91b03134e.zip
dev-python/fields-5.0.0-r2: revbump, fix tests, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/fields')
-rw-r--r--dev-python/fields/fields-5.0.0-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/fields/fields-5.0.0-r2.ebuild b/dev-python/fields/fields-5.0.0-r2.ebuild
new file mode 100644
index 000000000000..134ee06963cf
--- /dev/null
+++ b/dev-python/fields/fields-5.0.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Container class boilerplate killer"
+HOMEPAGE="https://github.com/ionelmc/python-fields"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/characteristic[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r \
+ -e "/--benchmark-disable/d" \
+ -e 's|\[pytest\]|\[tool:pytest\]|' \
+ -e '/^[[:space:]]*--doctest-modules[[:space:]]*$/ d' \
+ -i setup.cfg || die
+
+ rm -rf tests/test_perf.py || die
+ distutils-r1_python_prepare_all
+}