summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-28 07:26:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-28 07:43:52 +0100
commitf9a160a219973e9a9d4406a75d4fcea385bb1829 (patch)
tree10c019078dbdf2f66be23c72945f500908184ca6 /dev-python/fido2
parentdev-python/x-wr-timezone: Bump to 2.0.0 (diff)
downloadgentoo-f9a160a219973e9a9d4406a75d4fcea385bb1829.tar.gz
gentoo-f9a160a219973e9a9d4406a75d4fcea385bb1829.tar.bz2
gentoo-f9a160a219973e9a9d4406a75d4fcea385bb1829.zip
dev-python/fido2: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest1
-rw-r--r--dev-python/fido2/fido2-1.2.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index b0ea538f0381..c6d62a3f34c4 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -1,2 +1,3 @@
DIST fido2-0.9.3.tar.gz 217894 BLAKE2B ccc3a9b59045216037664b5bf4b969a79b86b300f67fc4253b563acbbee98912ea076996772f17b88141d2a36a933b4926de96f05c53e204d0bb4eaaa2daad6b SHA512 f105c347784cdfab88ab08852227d24f4bca623145f7f76bd066dadab6ada1eae751934fd4dc7436a5c5fb3a0ed2fc4d5c59bb2a93888d470028f0713ca7e09e
DIST fido2-1.1.3.tar.gz 252813 BLAKE2B f88ddd1c201aefddbf8c0a91040a121a3ba446229f90c17df6114c6b7fd3c047a4089475601f2d7d38d06fcd5fd14dba25177fa2b22360226a7c90d66137e978 SHA512 9ee226ab5762afe263c917d24ddfded9f3da40b38f97383c25c5fbfc3adc6085d3d218dc5f12b288689bf2e5e89fe9cecb2e40e45e5441d2001f945b336c2d0b
+DIST fido2-1.2.0.tar.gz 266369 BLAKE2B 6170fffe46c5d3baa79b061583ffa597690b7f636a6205bcafcc2d997d7a82d49388ce4f573511e4ade976e491bdabb24e16c8be23a6aba3cbb1a1e70437b218 SHA512 c9c7a47ed6608f2dcf06b38905708d64b85ca91ea2656b654474e3164a90b3feae36a0898cf984a4811f1f757e22d3c7ca3dad1ba909b6c8191e418b1a0f938c
diff --git a/dev-python/fido2/fido2-1.2.0.ebuild b/dev-python/fido2/fido2-1.2.0.ebuild
new file mode 100644
index 000000000000..41635cb38660
--- /dev/null
+++ b/dev-python/fido2/fido2-1.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="
+ https://github.com/Yubico/python-fido2/
+ https://pypi.org/project/fido2/
+"
+SRC_URI="
+ https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz
+"
+
+LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
+SLOT="0/1.0" # Bumped every time a backwards-incompatible version is released
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/cryptography-45[${PYTHON_USEDEP}]
+ <dev-python/pyscard-3[${PYTHON_USEDEP}]
+ examples? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}