summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-26 10:41:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-26 11:37:34 +0100
commitb529a9f9afa2b982836587932d5ba47862701364 (patch)
tree9b6b7c37ed951e16c49c652b8cbf36e63c070d1e /dev-python/etuples
parentsci-libs/gmsh: disable py3.7 (diff)
downloadgentoo-b529a9f9afa2b982836587932d5ba47862701364.tar.gz
gentoo-b529a9f9afa2b982836587932d5ba47862701364.tar.bz2
gentoo-b529a9f9afa2b982836587932d5ba47862701364.zip
dev-python/etuples: Bump to 0.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/etuples')
-rw-r--r--dev-python/etuples/Manifest1
-rw-r--r--dev-python/etuples/etuples-0.3.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/etuples/Manifest b/dev-python/etuples/Manifest
index 35627724877b..a16fbe5edd09 100644
--- a/dev-python/etuples/Manifest
+++ b/dev-python/etuples/Manifest
@@ -1 +1,2 @@
DIST etuples-0.3.4.gh.tar.gz 44650 BLAKE2B 4d0e7235d010ff10e01d4143858bbc2ee1516f66db35fb9c6acf054df898a605a49dc82e4eeaddcb7ab6e5ea9bbd5dec493ac5d1741c4d595756e0f4af0ed1c1 SHA512 4e2c2884cd741a1e85358678347dc65c994583ff700c6a1adaa561bd4446035ccca2e27855fbb5842012f7e2bfa90ef7fa1634e9b3cc43cf9c7006acd7b66595
+DIST etuples-0.3.5.gh.tar.gz 44924 BLAKE2B 81b603c851b89b3ec3556246d7dfc12a533632f4e99f8b784c4b9f46c3ee51fe7d370556e376a957e52c980b6e16fc93d85c597d31cee371fa2e5cbeec962c9e SHA512 df51ff42609a341c42009b650dadac2a6fb8ea85c3ccc6145ee2bdf6270ed9509d73196f8b0b789091918e93492f766d5fc242e2d5acc30074c171a2334a42fa
diff --git a/dev-python/etuples/etuples-0.3.5.ebuild b/dev-python/etuples/etuples-0.3.5.ebuild
new file mode 100644
index 000000000000..5d23977f1232
--- /dev/null
+++ b/dev-python/etuples/etuples-0.3.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python S-expression emulation using tuple-like objects"
+HOMEPAGE="
+ https://pypi.org/project/etuples/
+ https://github.com/pythological/etuples/
+"
+SRC_URI="
+ https://github.com/pythological/etuples/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest