summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-07-04 19:50:09 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-07-05 23:50:27 +0200
commit93a93bc81d9ea209d7bdadda9454827a3d4399aa (patch)
tree92a1c3e401aa4c12a2aacdcba031d13454d7a7e7 /dev-python/e4u
parentapp-admin/ansible: 2.5.6 bup (diff)
downloadgentoo-93a93bc81d9ea209d7bdadda9454827a3d4399aa.tar.gz
gentoo-93a93bc81d9ea209d7bdadda9454827a3d4399aa.tar.bz2
gentoo-93a93bc81d9ea209d7bdadda9454827a3d4399aa.zip
dev-python/e4u: version bump to 0.1_rc5.
Package-Manager: Portage-2.3.41, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9053
Diffstat (limited to 'dev-python/e4u')
-rw-r--r--dev-python/e4u/Manifest2
-rw-r--r--dev-python/e4u/e4u-0.1_rc5.ebuild (renamed from dev-python/e4u/e4u-0.1_rc4.ebuild)2
-rw-r--r--dev-python/e4u/files/change-emoji4unicode-url.patch14
-rw-r--r--dev-python/e4u/files/initialize-e4u-tests.patch11
4 files changed, 9 insertions, 20 deletions
diff --git a/dev-python/e4u/Manifest b/dev-python/e4u/Manifest
index c3f34aa14147..6b9e55cf805a 100644
--- a/dev-python/e4u/Manifest
+++ b/dev-python/e4u/Manifest
@@ -1 +1 @@
-DIST e4u-0.1rc4.tar.gz 50266 BLAKE2B 2cb878837ca34c7839e026b1f742ec23d9ee2c046406084ef10fca4c565b4661237ddf9f76620abc8db968dd5c521be4219752ff8ec4017326b57dc5de9b4ef0 SHA512 8ca0a0a160ddd1425be4f8a941d9767edac89edfaf5f5f14af840f3460ad91344186f8111711e0fb7af212d15af1f766d592e887511f820770b9f66818896a1d
+DIST e4u-0.1rc5.tar.gz 51001 BLAKE2B 32f8b1a32d0f1b51eb97169f0375cf725571c2c7df8cab7414483c997bc7e501c19339d2fbe287718cd50afc2451bc9e9a39d2b42b242657d9a52931f89cfa0e SHA512 d19085a767275c91e807517d714955c123e2dbe3c3904240e09ba115298474067f60393ab613af3eb1af8a09964b157acfc6d69dcaccc4493b014a9bc51e3662
diff --git a/dev-python/e4u/e4u-0.1_rc4.ebuild b/dev-python/e4u/e4u-0.1_rc5.ebuild
index 93b757abd30c..b52ae0edf6d2 100644
--- a/dev-python/e4u/e4u-0.1_rc4.ebuild
+++ b/dev-python/e4u/e4u-0.1_rc5.ebuild
@@ -25,7 +25,7 @@ DEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${MY_PV}"
-PATCHES=( "${FILESDIR}/change-emoji4unicode-url.patch" "${FILESDIR}/initialize-e4u-tests.patch" )
+PATCHES=( "${FILESDIR}"/change-emoji4unicode-url.patch )
python_test() {
esetup.py test
diff --git a/dev-python/e4u/files/change-emoji4unicode-url.patch b/dev-python/e4u/files/change-emoji4unicode-url.patch
index d356e7d68cae..ff9e54bf72a0 100644
--- a/dev-python/e4u/files/change-emoji4unicode-url.patch
+++ b/dev-python/e4u/files/change-emoji4unicode-url.patch
@@ -1,11 +1,11 @@
---- a/e4u/__init__.py 2013-06-13 09:14:06.000000000 +0200
-+++ b/e4u/__init__.py 2018-05-18 15:35:49.000000000 +0200
+--- a/e4u/__init__.py 2018-05-22 08:32:05.000000000 +0200
++++ b/e4u/__init__.py 2018-07-04 19:40:53.000000000 +0200
@@ -11,15 +11,15 @@
_loader = None
-def load(filename=None,
-- url=r"http://emoji4unicode.googlecode.com/svn/trunk/data/emoji4unicode.xml",
+- url=r"https://raw.githubusercontent.com/googlei18n/emoji4unicode/master/data/emoji4unicode.xml",
+def load(filename=r"/usr/share/e4u/emoji4unicode.xml",
+ url=None,
loader_class=None):
@@ -14,19 +14,19 @@
reload(filename, url, loader_class)
-def reload(filename=None,
-- url=r"http://emoji4unicode.googlecode.com/svn/trunk/data/emoji4unicode.xml",
+- url=r"https://raw.githubusercontent.com/googlei18n/emoji4unicode/master/data/emoji4unicode.xml",
+def reload(filename=r"/usr/share/e4u/emoji4unicode.xml",
+ url=None,
loader_class=None):
u"""reload google's `emoji4unicode` project's xml file. must call this method first to use `e4u` library."""
if loader_class is None:
---- a/e4u/loader.py 2013-06-13 09:14:06.000000000 +0200
-+++ b/e4u/loader.py 2018-05-18 15:36:01.000000000 +0200
+--- a/e4u/loader.py 2018-05-22 08:32:05.000000000 +0200
++++ b/e4u/loader.py 2018-07-04 19:43:05.000000000 +0200
@@ -32,7 +32,7 @@
self._translate_dictionaries = create_translate_dictionaries(self.symbols)
-- def load(self, filename=None, url=r"http://emoji4unicode.googlecode.com/svn/trunk/data/emoji4unicode.xml"):
+- def load(self, filename=None, url=r"https://raw.githubusercontent.com/googlei18n/emoji4unicode/master/data/emoji4unicode.xml"):
+ def load(self, filename=r"/usr/share/e4u/emoji4unicode.xml", url=None):
if filename:
xml = open(filename, 'r').read()
diff --git a/dev-python/e4u/files/initialize-e4u-tests.patch b/dev-python/e4u/files/initialize-e4u-tests.patch
deleted file mode 100644
index 4d9a25d5de99..000000000000
--- a/dev-python/e4u/files/initialize-e4u-tests.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/test/test.py 2013-06-13 09:14:06.000000000 +0200
-+++ b/test/test.py 2018-05-16 13:40:22.000000000 +0200
-@@ -7,6 +7,8 @@
- import unittest
- import e4u
-
-+e4u.load(filename=r"./e4u/data/emoji4unicode.xml")
-+
- DISPLAY_INFO = False
-
- class TestCaseAbstract(object):