summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-02-25 21:39:47 +0300
committerMichał Górny <mgorny@gentoo.org>2023-02-26 04:59:45 +0100
commitd5667dd0f13c3a0c8329a8db6793766c29d210e4 (patch)
treefa5e0e1ffad7c3e48d817adfd786e2e2c90e0ad3 /dev-python/doit-py
parentdev-util/lldb: Remove obsolete -DLLDB_USE_SYSTEM_SIX (diff)
downloadgentoo-d5667dd0f13c3a0c8329a8db6793766c29d210e4.tar.gz
gentoo-d5667dd0f13c3a0c8329a8db6793766c29d210e4.tar.bz2
gentoo-d5667dd0f13c3a0c8329a8db6793766c29d210e4.zip
dev-python/doit-py: update to EAPI8
Add python3_11 target, minor enhancements. Closes: https://bugs.gentoo.org/896776 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/doit-py')
-rw-r--r--dev-python/doit-py/Manifest1
-rw-r--r--dev-python/doit-py/doit-py-0.5.0-r1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/doit-py/Manifest b/dev-python/doit-py/Manifest
index a7cb600be8df..a0966693812b 100644
--- a/dev-python/doit-py/Manifest
+++ b/dev-python/doit-py/Manifest
@@ -1 +1,2 @@
+DIST doit-py-0.5.0.gh.tar.gz 15174 BLAKE2B 092f21549d3c088baf8a96b8dd7575304d08c7ae7b0472e7a890159247422060af06c1cc14064cd608bd59e71788067c5374953b16f4511971bb3018c0245cd4 SHA512 f9e70be30f47b7251bdb479762dabe655be898f9fe37fc5ac6608110a82863a08002271620569745f9ec2f47c03529c044a6ea74244b8bb6438b3fbe7e4c28f7
DIST doit-py-0.5.0.tar.gz 15174 BLAKE2B 092f21549d3c088baf8a96b8dd7575304d08c7ae7b0472e7a890159247422060af06c1cc14064cd608bd59e71788067c5374953b16f4511971bb3018c0245cd4 SHA512 f9e70be30f47b7251bdb479762dabe655be898f9fe37fc5ac6608110a82863a08002271620569745f9ec2f47c03529c044a6ea74244b8bb6438b3fbe7e4c28f7
diff --git a/dev-python/doit-py/doit-py-0.5.0-r1.ebuild b/dev-python/doit-py/doit-py-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..d8b9f86835b0
--- /dev/null
+++ b/dev-python/doit-py/doit-py-0.5.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="doit tasks for python stuff"
+HOMEPAGE="https://pythonhosted.org/doit-py/ https://github.com/pydoit/doit-py"
+SRC_URI="https://github.com/pydoit/doit-py/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ test? (
+ app-text/hunspell[l10n_en]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ dev-python/configclass[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest