summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-17 11:13:51 +0000
committerSam James <sam@gentoo.org>2023-02-17 11:13:51 +0000
commitd23fc28d2a86581f8a7a70d38101fe27d19f1d71 (patch)
tree77521309176056f9dfae0165c29dfc867b04eaca /dev-python/dockerpty
parentnet-misc/iperf: add 3.13 (diff)
downloadgentoo-d23fc28d2a86581f8a7a70d38101fe27d19f1d71.tar.gz
gentoo-d23fc28d2a86581f8a7a70d38101fe27d19f1d71.tar.bz2
gentoo-d23fc28d2a86581f8a7a70d38101fe27d19f1d71.zip
dev-python/dockerpty: enable py3.11, use PEP517
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/dockerpty')
-rw-r--r--dev-python/dockerpty/Manifest1
-rw-r--r--dev-python/dockerpty/dockerpty-0.4.1-r2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/dockerpty/Manifest b/dev-python/dockerpty/Manifest
index f45c3fbd7fb1..5421f5685cf6 100644
--- a/dev-python/dockerpty/Manifest
+++ b/dev-python/dockerpty/Manifest
@@ -1 +1,2 @@
+DIST dockerpty-0.4.1.gh.tar.gz 19608 BLAKE2B 1c7229bdd18100bb75a8ec80f0b8a636137efce40affb2bbadf27eef5ee13322ab92f9a3f77db0ef79c35366daf700550eb9a358534f7a1f1c2b92ec2cd4d5d0 SHA512 1f27a1d1cf9bfa21a77f2c0695334ec09a81ed5b70190b16fb23ec0e2ab4cb84af334b5e9275265eff2d8014aac5f96890276bed5775bb805c3f30260c99da70
DIST dockerpty-0.4.1.tar.gz 19608 BLAKE2B 1c7229bdd18100bb75a8ec80f0b8a636137efce40affb2bbadf27eef5ee13322ab92f9a3f77db0ef79c35366daf700550eb9a358534f7a1f1c2b92ec2cd4d5d0 SHA512 1f27a1d1cf9bfa21a77f2c0695334ec09a81ed5b70190b16fb23ec0e2ab4cb84af334b5e9275265eff2d8014aac5f96890276bed5775bb805c3f30260c99da70
diff --git a/dev-python/dockerpty/dockerpty-0.4.1-r2.ebuild b/dev-python/dockerpty/dockerpty-0.4.1-r2.ebuild
new file mode 100644
index 000000000000..96d7f33b72f1
--- /dev/null
+++ b/dev-python/dockerpty/dockerpty-0.4.1-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python library to use the pseudo-tty of a docker container"
+HOMEPAGE="https://github.com/d11wtq/dockerpty"
+SRC_URI="https://github.com/d11wtq/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="
+ test? (
+ >=dev-python/docker-py-0.7.0_rc2[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.4[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/six-1.3.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest