summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-auth-ldap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest2
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild44
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.2.6.ebuild42
-rw-r--r--dev-python/django-auth-ldap/files/docs.patch18
-rw-r--r--dev-python/django-auth-ldap/metadata.xml9
5 files changed, 115 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
new file mode 100644
index 000000000000..a2e1627574ec
--- /dev/null
+++ b/dev-python/django-auth-ldap/Manifest
@@ -0,0 +1,2 @@
+DIST django-auth-ldap-1.2.2.tar.gz 131086 SHA256 faa067b073f6ea73c1ceeb5e244187ae1b3cf4ec79846ff366fa996428434264 SHA512 676d1114faeb9a2956ed51c586afea7618c1bf62867d3525596599391f8327b8f22a075c4203311df88279c317ca37b9097b59e55a64330afee6eb1c5a9c9ac3 WHIRLPOOL ae84405b4855ad9701244ab6cbd5e5154d2e173e04896c27e0869680bb4e030b6847293bcc59ef4f7f56969778c7d403721bae0d7099e2f3724186908c7abbbd
+DIST django-auth-ldap-1.2.6.tar.gz 131385 SHA256 17671e1f0f1ef5c1242291f710956ba9446bf804ff907eab1fe533031b9411b5 SHA512 59d6d18ad2f890e26a728b9f45885d98d08d85a36bce0a28cd52e02f7c4a52def79d668c1948be37915fd0c3be72d50de983bf4a4b622ce7bbff7d3e040b63b7 WHIRLPOOL 5e673bc686f222e6704ca98f0ae8a7472bd85b6c33f3182f4a087d9a8b3174cdcd76521ce42033874979d00dee94cbdc2db5da32b8bdceb474edf3e8b498d1ee
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild
new file mode 100644
index 000000000000..56d66ed3ed5f
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# Although setup.py claims to support py3, python-ldap does not
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="http://pypi.python.org/pypi/django-auth-ldap http://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-2.0[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/mockldap-0.2[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+#S="${WORKDIR}"/psagers-${PN}-80379ce59e6b
+
+PATCHES=( "${FILESDIR}"/docs.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" test/manage.py test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.2.6.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.2.6.ebuild
new file mode 100644
index 000000000000..03f5f9123711
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.2.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# Although setup.py claims to support py3, python-ldap does not
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="http://pypi.python.org/pypi/django-auth-ldap http://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-2.0[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/mockldap-0.2[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/docs.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" test/manage.py test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-auth-ldap/files/docs.patch b/dev-python/django-auth-ldap/files/docs.patch
new file mode 100644
index 000000000000..c4e918fac538
--- /dev/null
+++ b/dev-python/django-auth-ldap/files/docs.patch
@@ -0,0 +1,18 @@
+Avoid unwanted d'loading for un-needed ojects.inv files
+diff -ur django-auth-ldap-1.1.4.orig/docs/source/conf.py django-auth-ldap-1.1.4/docs/source/conf.py
+--- docs/source/conf.py 2013-03-10 06:01:09.000000000 +0800
++++ docs/source/conf.py 2013-05-18 23:14:35.761187583 +0800
+@@ -29,13 +29,6 @@
+ 'daldocs',
+ ]
+
+-intersphinx_mapping = {
+- 'python': ('http://docs.python.org/', None),
+- 'django': ('https://docs.djangoproject.com/en/dev/',
+- 'https://docs.djangoproject.com/en/dev/_objects/'),
+- 'pythonldap': ('http://python-ldap.org/doc/html/', None),
+-}
+-
+ # Add any paths that contain templates here, relative to this directory.
+ templates_path = ['../_templates']
+
diff --git a/dev-python/django-auth-ldap/metadata.xml b/dev-python/django-auth-ldap/metadata.xml
new file mode 100644
index 000000000000..29b8b314b8c2
--- /dev/null
+++ b/dev-python/django-auth-ldap/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">django-auth-ldap</remote-id>
+ <remote-id type="bitbucket">psagers/django-auth-ldap</remote-id>
+ </upstream>
+</pkgmetadata>