summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-13 20:46:00 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-13 21:53:27 +0200
commit31cb922bf3154fdf3b63ed6526f3fc1288b4fbc2 (patch)
treecdb75d7a6ea7cef83eb79318da029b5d277ba1e5 /dev-python/dj-database-url
parentdev-python/discogs-client: add 2.6 (diff)
downloadgentoo-31cb922bf3154fdf3b63ed6526f3fc1288b4fbc2.tar.gz
gentoo-31cb922bf3154fdf3b63ed6526f3fc1288b4fbc2.tar.bz2
gentoo-31cb922bf3154fdf3b63ed6526f3fc1288b4fbc2.zip
dev-python/dj-database-url: add 1.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/dj-database-url')
-rw-r--r--dev-python/dj-database-url/Manifest1
-rw-r--r--dev-python/dj-database-url/dj-database-url-1.2.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dj-database-url/Manifest b/dev-python/dj-database-url/Manifest
index c509d39cdb43..7278dce3f1f7 100644
--- a/dev-python/dj-database-url/Manifest
+++ b/dev-python/dj-database-url/Manifest
@@ -1,2 +1,3 @@
DIST dj-database-url-1.0.0.gh.tar.gz 11355 BLAKE2B 9ea50eb2646367333556133020a59f332cb69e05fb392f328558f77cb03ffa968cf62241f3823e28600799a1399ac1335b90477a26a4931b0df7b695b502e9be SHA512 35ca0c05910812e10bf63b061afb434ac7c562e3d994b6e452250fe4ec95983fe8353aec0df9c7638a990684e612863ddada5be48485a1db3120e110f6d0fa94
DIST dj-database-url-1.1.0.gh.tar.gz 12095 BLAKE2B 61d32e20ce06451300474f88debb12e960ea6efce8706d6f61991eb204cc8be62f40f38272d9ef177dfa6f4f8a7502c38d17e4c2b01ccb2b256b1dc5329c8dd7 SHA512 4c2ee396daf1a8052a981f8b8df1ba02405020bd4ce3e36df0e34d8be745e5b71a5eb7fef8fc7bff05a8846e9aa1d29857d71e9ba7aa2b5ac0fcb9fabc9f0e60
+DIST dj-database-url-1.2.0.gh.tar.gz 12479 BLAKE2B cc3fed00cd7329a9ee8f3ced5830cf05b7046960ae6397c68b8e67e0609c0284dba01a1736447b45f219290405a0ab4720267feba276b453555e3b8ac2f0d88a SHA512 72b713a3a1ad4c70d857c5c72e671095ef1b7ec8ebd19902296ea49b63b9bf6d0084d03561c8fb47c533da431b44ee17651b45f3f699faceaed0ee6bfe7c921a
diff --git a/dev-python/dj-database-url/dj-database-url-1.2.0.ebuild b/dev-python/dj-database-url/dj-database-url-1.2.0.ebuild
new file mode 100644
index 000000000000..c30f6849ca02
--- /dev/null
+++ b/dev-python/dj-database-url/dj-database-url-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Database URLs in your Django Application"
+HOMEPAGE="
+ https://github.com/jazzband/dj-database-url/
+ https://pypi.org/project/dj-database-url/
+"
+SRC_URI="
+ https://github.com/jazzband/dj-database-url/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest