summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:16:42 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit51d00b337bb888f42edaae303293079ed3c3b21d (patch)
tree31a0bc6a9b715b2da10bdc97024256bc22d52126 /dev-python/distlib
parentdev-python/cryptography-vectors: Add python3.5 support (diff)
downloadgentoo-51d00b337bb888f42edaae303293079ed3c3b21d.tar.gz
gentoo-51d00b337bb888f42edaae303293079ed3c3b21d.tar.bz2
gentoo-51d00b337bb888f42edaae303293079ed3c3b21d.zip
dev-python/distlib: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/distlib-0.2.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/distlib/distlib-0.2.1-r1.ebuild b/dev-python/distlib/distlib-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..7df0c549df73
--- /dev/null
+++ b/dev-python/distlib/distlib-0.2.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distribution utilities"
+HOMEPAGE="https://pypi.python.org/pypi/distlib https://bitbucket.org/vinay.sajip/distlib https://github.com/vsajip/distlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+python_test() {
+ sed \
+ -e '/PIP_AVAILABLE/s:True:False:g' \
+ -i tests/*py || die
+ PYTHONHASHSEED=0 esetup.py test
+}