summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/cosmolopy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/cosmolopy')
-rw-r--r--dev-python/cosmolopy/Manifest1
-rw-r--r--dev-python/cosmolopy/cosmolopy-0.1.104-r1.ebuild42
-rw-r--r--dev-python/cosmolopy/metadata.xml10
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/cosmolopy/Manifest b/dev-python/cosmolopy/Manifest
new file mode 100644
index 000000000000..1a8c94c4127b
--- /dev/null
+++ b/dev-python/cosmolopy/Manifest
@@ -0,0 +1 @@
+DIST CosmoloPy-0.1.104.tar.gz 65162 SHA256 f70486c362230ece215a974ef12ba7c9969598a220ecba64de19d0fcd5674e75 SHA512 b79b5b264a6bdd68082fc3f62f40957421d9a6914d1623cc89bac9b64598e5fca5d52290632ab55878c893223aeb3283c9b088987a0927d2c22160bc521359fa WHIRLPOOL 7155a20339a3548b5c194dc22efe62bf30b45c626c13d8a6e2c4a76ab37cbf097cda2ce94bff435f387bb8ed303c83a70cefc3e979f1a04e1b0b14726a4db978
diff --git a/dev-python/cosmolopy/cosmolopy-0.1.104-r1.ebuild b/dev-python/cosmolopy/cosmolopy-0.1.104-r1.ebuild
new file mode 100644
index 000000000000..74fc1c2bee66
--- /dev/null
+++ b/dev-python/cosmolopy/cosmolopy-0.1.104-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7)
+
+inherit distutils-r1
+
+MY_PN=CosmoloPy
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Cosmology routines built on NumPy/SciPy"
+HOMEPAGE="http://roban.github.com/CosmoloPy/ http://pypi.python.org/pypi/CosmoloPy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="dev-python/nose[${PYTHON_USEDEP}]
+ dev-lang/swig
+ doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )"
+RDEPEND="sci-libs/scipy[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ if use doc; then
+ epydoc -n "CosmoloPy - Cosmology routines built on NumPy/SciPy" \
+ --exclude='cosmolopy.EH._power' --exclude='cosmolopy.EH.power' \
+ --no-private --no-frames --html --docformat restructuredtext \
+ cosmolopy/ -o docAPI/ || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docAPI/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/cosmolopy/metadata.xml b/dev-python/cosmolopy/metadata.xml
new file mode 100644
index 000000000000..c931c4e1666e
--- /dev/null
+++ b/dev-python/cosmolopy/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>sci-astronomy</herd>
+ <longdescription lang="en">CosmoloPy is a package of cosmology routines built on NumPy/SciPy.</longdescription>
+ <upstream>
+ <remote-id type="pypi">CosmoloPy</remote-id>
+ </upstream>
+</pkgmetadata>