summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 22:01:01 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 22:11:07 +0200
commit9ab4456385a6cc90d2f0481e6b975dfa1f846034 (patch)
treeabeb1c21ef95dfb49141bceff0c9598da2d2264c /dev-python/chardet
parentdev-python/soupsieve: Enable py3.11 (diff)
downloadgentoo-9ab4456385a6cc90d2f0481e6b975dfa1f846034.tar.gz
gentoo-9ab4456385a6cc90d2f0481e6b975dfa1f846034.tar.bz2
gentoo-9ab4456385a6cc90d2f0481e6b975dfa1f846034.zip
dev-python/chardet: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/chardet')
-rw-r--r--dev-python/chardet/chardet-4.0.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/chardet/chardet-4.0.0-r1.ebuild b/dev-python/chardet/chardet-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..428ca399a801
--- /dev/null
+++ b/dev-python/chardet/chardet-4.0.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="
+ https://github.com/chardet/chardet/
+ https://pypi.org/project/chardet/
+"
+SRC_URI="
+ https://github.com/chardet/chardet/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest