summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-15 05:11:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-15 05:11:11 +0200
commitce3a8373215a8afca2da644e351f881f4eda3c51 (patch)
tree3b33d819ede040435b054ec20fb0b020b3e9e6d3 /dev-python/cfn-lint
parentdev-python/ubelt: Bump to 1.3.0 (diff)
downloadgentoo-ce3a8373215a8afca2da644e351f881f4eda3c51.tar.gz
gentoo-ce3a8373215a8afca2da644e351f881f4eda3c51.tar.bz2
gentoo-ce3a8373215a8afca2da644e351f881f4eda3c51.zip
dev-python/cfn-lint: Bump to 0.77.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.77.9.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index c335b47e0ea8..980766813033 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -2,3 +2,4 @@ DIST cfn-lint-0.77.5.tar.gz 3513226 BLAKE2B edff62682027d87fc4f0934aba83ca1cbd83
DIST cfn-lint-0.77.6.tar.gz 3554363 BLAKE2B abd496cdb72e1032c92a6489da12a4ffb4f83bba994067f9e2d333e55a13ea22d07db880dd3acca208f9b8328c17fe98540cec2847dac32ad87b2662aa0047e4 SHA512 b36c781dbd3294d6f2cfe43f617832170e47c9c9502845a551e6a9263e28dc6de99c77abd998699a2fcb6f08535daff615b17072c3ad1fe9c10853890a71989f
DIST cfn-lint-0.77.7.tar.gz 3554332 BLAKE2B b669b9f97523933eb5549f7b2d67a132aef2236301b24094a0b74e9198d49121d4ec173c99d74b554b77eee2765b4ceb97126f2ccfab121393bc68e34cfb8147 SHA512 124ab4b96963f4971a25535852290ee71b5eed82e85a4101b3aa0469213b1006bfe8ae3d384f1acf236a0fa9915a24999b00f31f0d6ddbedbdaba123bfbb823b
DIST cfn-lint-0.77.8.tar.gz 3578363 BLAKE2B 33fbc0dd76a025425453bf39da0cd1c9ffc15b057735e2add0a54fe387377824839ab34fb37216db4fe0cc05f60878b4ac828aceecd888d510612d9c44d8473f SHA512 7fc71965d33df29557de996e2ba0e911e681b5d220e69346a26448c1e04f3cd40f7e17b933cde695ad5aa6170d46981834efa19103e50d6690b4d476d13f82ba
+DIST cfn-lint-0.77.9.tar.gz 3477918 BLAKE2B dd575c9610289b5fd256b7ddd11985a6b5790706d2d8d79409bea4b3c6600d680931893ce8f9b38724c14348fbb6023bd43dbd932c822547d923f5eaa43552bc SHA512 f861fb4b6e8c95e6ac9cda564b9f65c639696a1df16408500fab9a07c317e4663a1bbde87e245536b555a664f325441bd802a703ede7cd51f16be473afe34966
diff --git a/dev-python/cfn-lint/cfn-lint-0.77.9.ebuild b/dev-python/cfn-lint/cfn-lint-0.77.9.ebuild
new file mode 100644
index 000000000000..6f296e7c5910
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.77.9.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.68.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}