summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-28 17:16:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-28 17:17:05 +0200
commit69c23884f61839e8c99c8cce39150c933b704251 (patch)
treebb04ca172e74f2ad5e39b56a40a98b3ac3862575 /dev-python/cfn-lint/cfn-lint-0.73.2.ebuild
parentdev-python/aws-sam-translator: Remove old (diff)
downloadgentoo-69c23884f61839e8c99c8cce39150c933b704251.tar.gz
gentoo-69c23884f61839e8c99c8cce39150c933b704251.tar.bz2
gentoo-69c23884f61839e8c99c8cce39150c933b704251.zip
dev-python/cfn-lint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint/cfn-lint-0.73.2.ebuild')
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.73.2.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/cfn-lint/cfn-lint-0.73.2.ebuild b/dev-python/cfn-lint/cfn-lint-0.73.2.ebuild
deleted file mode 100644
index a8d6bacd111b..000000000000
--- a/dev-python/cfn-lint/cfn-lint-0.73.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="CloudFormation Linter"
-HOMEPAGE="
- https://github.com/aws-cloudformation/cfn-lint/
- https://pypi.org/project/cfn-lint/
-"
-SRC_URI="
- https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/aws-sam-translator-1.59.0[${PYTHON_USEDEP}]
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
- dev-python/junit-xml[${PYTHON_USEDEP}]
- <dev-python/networkx-4[${PYTHON_USEDEP}]
- >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
- >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # TODO
- test/unit/module/test_template.py::TestTemplate::test_build_graph
- # requires git repo
- test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
- # Internet
- test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
- test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
-)
-
-src_prepare() {
- # unpin the deps
- sed -e 's:~=[0-9.]*::' -i setup.py || die
- distutils-r1_src_prepare
-}