summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-12 09:19:49 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-12 10:09:46 +0100
commit43ca67fe0dab7451864c2d2a55c871faa404c835 (patch)
treea21da3e75d580c1ba473e59c6587396ffd4570ef /dev-python/cffi
parentdev-python/asteval: Add python@ as co-maint (diff)
downloadgentoo-43ca67fe0dab7451864c2d2a55c871faa404c835.tar.gz
gentoo-43ca67fe0dab7451864c2d2a55c871faa404c835.tar.bz2
gentoo-43ca67fe0dab7451864c2d2a55c871faa404c835.zip
dev-python/cffi: Bump to 1.14.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/Manifest1
-rw-r--r--dev-python/cffi/cffi-1.14.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index 068a1f07b8bb..69632830f0b0 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -1 +1,2 @@
DIST cffi-1.14.4.tar.gz 471302 BLAKE2B 9722e517c99b6df239f59235baea76957900dc8566ff04c8d1fd367d20ad5f5437212bdb5e4e98aca303121e79411634fcb5e4e72179ecb3007d4f0eee68c9f2 SHA512 b2c54a805ead93c5dd8531d7f0f7e4b44be8f07bfcb1af2f19eb6d325b4e846cae23f16a5bcc777ba019d1213f013611614ade798e195f5b4f6b7904c9cb6e3a
+DIST cffi-1.14.5.tar.gz 475055 BLAKE2B d8a1f83aace8329216f5d36b2e8a27f62803fe9ad12c2d29aa1b3f730d1beb8bad0f50e17102c8673471a7bef57b0755157c4e1bf1a50779ed20b1cfcbb2043a SHA512 7428b3f6e4ee9f3b91011e43304dd63e5cc48479120ae58298c646c1ec1f5c24525d5f08655a7fed70c5fad7ae0c2e0539e512b5fa49d2bc57669c4ab703cc2a
diff --git a/dev-python/cffi/cffi-1.14.5.ebuild b/dev-python/cffi/cffi-1.14.5.ebuild
new file mode 100644
index 000000000000..fb0d73cf7ae2
--- /dev/null
+++ b/dev-python/cffi/cffi-1.14.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# DO NOT ADD pypy to PYTHON_COMPAT
+# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.org/project/cffi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libffi:="
+RDEPEND="${DEPEND}
+ dev-python/pycparser[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx doc/source
+
+PATCHES=(
+ "${FILESDIR}"/cffi-1.14.0-darwin-no-brew.patch
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *darwin* ]] ; then
+ # Don't obsessively try to find libffi
+ sed -i -e "s/.*\-iwithsysroot\/usr\/include\/ffi.*/\tpass/" setup.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+}
+
+python_test() {
+ "${EPYTHON}" -c "import _cffi_backend as backend" || die
+ pytest -x -vv \
+ --ignore testing/test_zintegration.py \
+ --ignore testing/embedding \
+ c/ testing/ \
+ || die "Testing failed with ${EPYTHON}"
+}