summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-06 03:59:31 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-06 05:10:04 +0100
commit3c6cd48e05cca8f58542e42fa84afff63e3211fa (patch)
treec55040d81938c4d7e25ed6f5efadbc3ef5db0e1d /dev-python/botocore
parentsys-apps/flatpak: Remove broken selinux USE (diff)
downloadgentoo-3c6cd48e05cca8f58542e42fa84afff63e3211fa.tar.gz
gentoo-3c6cd48e05cca8f58542e42fa84afff63e3211fa.tar.bz2
gentoo-3c6cd48e05cca8f58542e42fa84afff63e3211fa.zip
dev-python/botocore: Bump to 1.36.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.36.14.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 48c338fe55bd..fecbd55fd5ee 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,5 +1,6 @@
DIST botocore-1.36.11.gh.tar.gz 14197086 BLAKE2B 471c4d4d8433c5ce577b76e3dc70e9cbc0aee52f8c06765c1d965b437e75b44b4d62ea472abf612266ebf718300aca11f39fce90abe5d5811a37bcbe686d09de SHA512 0cf405e0fd7466a631bfbf3c4d0ad46b7c6da787715d9d70362cd5ed869ecfcf26ce7465daec220c9ffb858a1171439088e42a72665726ba5b511ef551cdcf3a
DIST botocore-1.36.12.gh.tar.gz 14196487 BLAKE2B da045773e32f6a7b76f23cb68a8492fd61410e6c374968662612ead08f970624c685cdc14e6eebf01c77b4c0cac6b859313fd7d59c98b34786c863baa4a397cc SHA512 8909e431349634326ed2a88defade4c1c55969fffebcad8fc7acac0425cb7d6ae072b864d6102c8cdc898192af6e1f8fa990c877056bcba4fcc0b3fade7cb752
DIST botocore-1.36.13.gh.tar.gz 14200421 BLAKE2B 1caf60ecac0723f337bc2d742b4b6d01170c00baec704fcf4d5225103efff000a63d2cd7e066887e896217f966d4f47ddbff41c601e549e192ceb6ae8735fb27 SHA512 e79574640d5d35861017a6c26d96778299a64369219df467e409b45e9d632a5a11d92dee113c668747cac40e9efb70925f2e61fa99802408dcd8d13378b55f3c
+DIST botocore-1.36.14.gh.tar.gz 14200318 BLAKE2B d2711287a16723db9ab4220e405fda2a71d382a779f3d53873b79a25357d7930c1593ca9edbd49a678c12b537bd2d4768d6ff7adb66dcf53bfe7f8ae608ffa2a SHA512 91878033f7f267a449433da90017379892046898e62941c3d835d90ef94f0c70efe9a325e36ff1133bf8e78875cc6b80eeea7a31b7e40901fbaaa40c189c5c9b
DIST botocore-1.36.2.gh.tar.gz 14197789 BLAKE2B 21441cd52052d117ce05e425c13f34941dcc1ca26a03e2e7eefb6c82584d7faffb548435ebb6b716b72db8149cfe6a3378b79f9174c676fd193c194501b0c844 SHA512 45d9515c493b238a003e5ad264b152b68a62e7ca140ea13111865a4b7c674a7b309a0f550f9782c37966b95c114136b8788f00ba0c83ed4bc61521b593376594
DIST botocore-1.36.6.gh.tar.gz 14173329 BLAKE2B 1eea293adad312439f2c60e0f73f721fa207439af2918fb5db98304a565e44d33f953f517e5526e865cbf58751892be4a6cc275545f295638109ee4051d2a276 SHA512 bcd1077bfeb5709e8c6224560f7974d70a884310539b531f520b20446aeaf3aa5d9aba6cbd19d75526d34dd7ab68be578f5ece7bddf7986997f9f5bbd5cee905
diff --git a/dev-python/botocore/botocore-1.36.14.ebuild b/dev-python/botocore/botocore-1.36.14.ebuild
new file mode 100644
index 000000000000..9e1580d45581
--- /dev/null
+++ b/dev-python/botocore/botocore-1.36.14.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}