summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-12 09:06:01 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-12 10:40:20 +0100
commit191bb99e62bebddefba0fb1445abd165e1b050d7 (patch)
tree9a665bd5b89fc72b048dde96b76dd8a9cd9ac438 /dev-python/botocore
parentmedia-sound/easyeffects: Keyword 6.1.4 x86, #807265 (diff)
downloadgentoo-191bb99e62bebddefba0fb1445abd165e1b050d7.tar.gz
gentoo-191bb99e62bebddefba0fb1445abd165e1b050d7.tar.bz2
gentoo-191bb99e62bebddefba0fb1445abd165e1b050d7.zip
dev-python/botocore: Bump to 1.23.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.23.4.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 125672b15358..054b1959cf9f 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.22.5.tar.gz 8301083 BLAKE2B 91f9d38e7c5bcb0b8f58c04547ad45489f58
DIST botocore-1.23.1.tar.gz 8353252 BLAKE2B e29dc3a2112c24f244d25336964605ba14a07f9db3f0462db911f9a1009846dc3601ae27bad05e8e58161e911a20ecbaf1f280bd61204a7392906f0553dcec64 SHA512 6938f54a98474aa0bb3c73249f81bc68cb364d381af3f08ac698d66b9f03c2b3649a253bafb57a6f525757f459a8c3da775370f64984be4bca0f2d4310f7a367
DIST botocore-1.23.2.tar.gz 8356426 BLAKE2B e8ab05b2adb4892460e681ac815461fd917005dc71baf7996b621855c69f5871e012441e3b788dc3d128e615607a711bc2705e65ed1eeefa9fd1b97d980a79af SHA512 a2a741ec5a58a3fce9002f719e03bc2e3cb86f85c84868167b38820e36b16d0a495b0c74b97479f6e0f976b9a0fedfe968f8d738217f61ba780a47a7a046ffb4
DIST botocore-1.23.3.tar.gz 8367493 BLAKE2B 6e7c27dd69d1256b1d874b330537fb76dae348986ba5764f0568b1e1092b3bb1c069aedb3e6410562a8210a615ca4b1f792fe05d531a08c7c015c47f8ca5f053 SHA512 a7246fbe64df68f49755008de542cce4c166e2421f339cdeb5e45a9e66562bbf9e497b1fdb6014fceedd10db9d1d96d38c19bc77c5d68bec4259621ab0ed0429
+DIST botocore-1.23.4.tar.gz 8368440 BLAKE2B 62756f2449b66bc970fd9b391afca8e2a71ffb5cbb3d7c33938916bbd4da29bca8e616000554eb25dc0f5f40143c6dbb381da09cbebd37a66ec2f3d40c0863d8 SHA512 417e6b2b4d18acb03eba8c3e5a58ed0c790d630fedb571e33e5e79020272442078c3276c5be9853a815f1b0b2b5143e85bc2ed3f46ca8cee2f7fe45fa59c5bfb
diff --git a/dev-python/botocore/botocore-1.23.4.ebuild b/dev-python/botocore/botocore-1.23.4.ebuild
new file mode 100644
index 000000000000..7337877443c9
--- /dev/null
+++ b/dev-python/botocore/botocore-1.23.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit}
+}