summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-02 23:35:30 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 10:11:06 +0100
commit8a2ac9088fb4563e6fdb06ef320a1942d3409f46 (patch)
tree194d1008ddfa2775a99b1145b65362309f368fa7 /dev-python/boto
parentmedia-video/ffmpeg: bump 3.3 branch to 3.3.6 (diff)
downloadgentoo-8a2ac9088fb4563e6fdb06ef320a1942d3409f46.tar.gz
gentoo-8a2ac9088fb4563e6fdb06ef320a1942d3409f46.tar.bz2
gentoo-8a2ac9088fb4563e6fdb06ef320a1942d3409f46.zip
dev-python/boto: Clean old up
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/Manifest2
-rw-r--r--dev-python/boto/boto-2.38.0.ebuild48
-rw-r--r--dev-python/boto/boto-2.42.0.ebuild55
3 files changed, 0 insertions, 105 deletions
diff --git a/dev-python/boto/Manifest b/dev-python/boto/Manifest
index b070eb84485d..ea3befd350c8 100644
--- a/dev-python/boto/Manifest
+++ b/dev-python/boto/Manifest
@@ -1,4 +1,2 @@
-DIST boto-2.38.0.tar.gz 1423863 BLAKE2B 074a379af19d4a63a06f0c5e257fe5ec30e04e5e6107c02a2da402991006ac73163d23099ec45a6396e2f09c66ac43111c6daf82ba4da97ec4c8d75b6a7b2cbf SHA512 577672007348db846d041c0906806c62eb77653b1335645cc852c603f5d32991ca648aacb884676af02043914c91ab6f41666b36b5b1ae23a3a354bdf9f3f75a
DIST boto-2.41.0.tar.gz 1440323 BLAKE2B 9d72fcd09cbf57d22dc45d42699af8cecef6f2c8e4009c9d70b54a9b84e23801ecbb5f7bc484692ca93ae302793b4d2f511c1209bcd33d0703a39b809bda1e00 SHA512 ffb503e8f7ec84ec973e109ae9524e1db2ef5f34d9424c380eed9a85871f07f8c9c798ca358fefd772ff45a72226bb02eebbbf6ab2d56b2442c41ede736f6f5e
-DIST boto-2.42.0.tar.gz 1442326 BLAKE2B 7b827d8905bb4dd28bc7e79ca92fc5197e3fbc34b61af4223581efc452288ca3f91071d5e8702afca3f934c9c1cc2bc1aeaf0a3f206054fe8784c9ad42ba5912 SHA512 5f45d56ef0d5b64f1f585f4d144cafd1bd2b05f1b0ec02748c27057f91ed9d94228ea2c24f4f081d4424285eecd1b749ca65952e769c4e94db0b944d79670076
DIST boto-2.48.0.tar.gz 1461372 BLAKE2B 0069ddc6def7d8698471bd66a5d8d4b62d49f49138036b3ae6a9655e7b7432af5449f2812e83f2012be2f01e93a61d9608157c9fd4ea0a52f8801e31877a78a7 SHA512 ce8e302b059ef31e81078ef21999b96b8770d2ef0c70358624c8cc6a79b1a43a78e1c206cbcba50eafb9c964c4eda5b9b0b127ea9523dcf7438453b4b2293f9f
diff --git a/dev-python/boto/boto-2.38.0.ebuild b/dev-python/boto/boto-2.38.0.ebuild
deleted file mode 100644
index 8d7ac9a20b85..000000000000
--- a/dev-python/boto/boto-2.38.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Amazon Web Services API"
-HOMEPAGE="https://github.com/boto/boto https://pypi.python.org/pypi/boto"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# requires Amazon Web Services keys to pass some tests
-RESTRICT="test"
-
-python_test() {
- "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- # Appease the doc build and supply a file for _static
- # the usual emake -C docs doesn't work under this authorship
- cd docs && mkdir source/_static || die
- emake html
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/boto/boto-2.42.0.ebuild b/dev-python/boto/boto-2.42.0.ebuild
deleted file mode 100644
index 95e096af80a7..000000000000
--- a/dev-python/boto/boto-2.42.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Amazon Web Services API"
-HOMEPAGE="https://github.com/boto/boto https://pypi.python.org/pypi/boto"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# requires Amazon Web Services keys to pass some tests
-RESTRICT="test"
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_test() {
- "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- # Appease the doc build and supply a file for _static
- # the usual emake -C docs doesn't work under this authorship
- cd docs && mkdir source/_static || die
- emake html
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}