summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-20 08:23:37 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-20 09:25:09 +0200
commitfb6243f5c33e8fada006162e9f73eb6e4beab8fc (patch)
treee1ac44e2ea8d0d6d1cb495b18b28d007a8d26662 /dev-python/boto3
parentdev-python/botocore: Bump to 1.20.76 (diff)
downloadgentoo-fb6243f5c33e8fada006162e9f73eb6e4beab8fc.tar.gz
gentoo-fb6243f5c33e8fada006162e9f73eb6e4beab8fc.tar.bz2
gentoo-fb6243f5c33e8fada006162e9f73eb6e4beab8fc.zip
dev-python/boto3: Bump to 1.17.76
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.76.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index dec6e58a60d8..2a27f1ba88f8 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -11,3 +11,4 @@ DIST boto3-1.17.72.tar.gz 370275 BLAKE2B 2a6923fb9ca0a67e9096844cf66a3dbf74e77eb
DIST boto3-1.17.73.tar.gz 371093 BLAKE2B 1259a4c8ad0c87cae66c6f30c70ea785927669f82ba3fe196db30e7dd8c92f940928a25c4cb263d3b9f0c9944a4dbf8d0cd4dc52770d60286a50ca4830d3129a SHA512 582ced34557e3ce20628a5093c80f7a9231e010da4a9c4f7669b7c04f1eae8c4edf050b75fc00675f03d4e9fbb3dbd97441cd9a99c7e050a3914f072810a8aeb
DIST boto3-1.17.74.tar.gz 371719 BLAKE2B f6d44206a14cdf395c8963be048e81391ecbf6817b1c00e1cd081abf111df8bd85c05fa1c04b013de7e6d916835e4876cc961891c8d52d8a32e41713080ed96e SHA512 a79012072238286561ab43ca7bb9f24236e858e0bf550be9a074517145445d0d520cc207683d99f6f704416f617b5f89468c87357223db9564e4310a2a2676f1
DIST boto3-1.17.75.tar.gz 372223 BLAKE2B 5502d43dd76206a57793593c85b5c84a126c8bd4b8e1ac6c72b65a70a1f5494a46db2a0f97cd7218f02fa4ffa53094202823a50b652650f21672be990242b25b SHA512 b7c6aeec402b0dcff2681f66714b5de77206873f4b554ab5a9436de473ce52c20c84107d18e0cb53badd7d6a68a5be53e0967a1d18f92935f6c27b3c2c154eaf
+DIST boto3-1.17.76.tar.gz 373664 BLAKE2B 2c38008fbe459ba0382d48f1e1bcf896fb1f341cba27f1ee9b7a2e186f71ba38a36edd1b123fca8ea66abddf81491005fa17847a447f300647f13b66bd4c1525 SHA512 3e3bf35bac59d62a23aa26db5d328e6ed07aebe87449037f11f2561514fbb877bb268942504c2f204a27eb19be6e076f36f59b635ca77e83c4c40b9371e76e92
diff --git a/dev-python/boto3/boto3-1.17.76.ebuild b/dev-python/boto3/boto3-1.17.76.ebuild
new file mode 100644
index 000000000000..5577742efeb7
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.76.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}