summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-20 05:40:49 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-20 06:19:17 +0200
commitf2dd3d2d73fb9a0a4c5a95bbec2edbab124f578e (patch)
tree4166084297bc3a7ed16707430bdb5ea73f6a5b1d /dev-python/boto3
parentdev-python/botocore: Bump to 1.31.67 (diff)
downloadgentoo-f2dd3d2d73fb9a0a4c5a95bbec2edbab124f578e.tar.gz
gentoo-f2dd3d2d73fb9a0a4c5a95bbec2edbab124f578e.tar.bz2
gentoo-f2dd3d2d73fb9a0a4c5a95bbec2edbab124f578e.zip
dev-python/boto3: Bump to 1.28.67
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.67.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index b9e5911a8e6d..2d59355cad2c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -6,3 +6,4 @@ DIST boto3-1.28.63.gh.tar.gz 713769 BLAKE2B f2e300458934893bb6d2186e900c4ba9abbd
DIST boto3-1.28.64.gh.tar.gz 714823 BLAKE2B b051c57d2852699d2c18472629934b97e76f30b1e6e0f398fde113771146cd65f8042bb8622884294fb802424b7beb498648d558f6d5cfc3dd48b1100dafc2d2 SHA512 ca0042e173c4a35dc9d6ab8ed362d3308753d3722bb4cf25302fd0018c5d94e66a2ea288610192ad5a353ca54f0ab8f1942224269935b1fe3444b2e70842da13
DIST boto3-1.28.65.gh.tar.gz 715573 BLAKE2B 24cf962b2b9e5c52f0e8d86e9acd730c4fe48bd7634ac65ccdf344985e82c51af05ff10f903cbde5048e8510adc5a83992cf2ad4ddf880435c121b20f981a6f6 SHA512 ea8ff1b72b5b8db00c959abf522a7aaf53bccf9b1e06f8ce70052cc752d18b73a8bc75d6bd97bd0740acac5bf3fd68f6fa39fc8aa084128291940c93d6745bf1
DIST boto3-1.28.66.gh.tar.gz 715939 BLAKE2B 4fda459ac4b066eae30a9f12ea53f2842dff2e4055cac8462ce147cbf2a77d4283ce6d814cefd0ecaff609d3b9401fe9216a1f54d464d2a1d64514ffebbc8352 SHA512 e44a59e124cac7d817a8fcc09004b557387369d5d02e55675e3ef5345a54f1ec5b60dc9558e1a1ae778841dbe7c4d29f27ca8ff066128c351349109d6f95aeab
+DIST boto3-1.28.67.gh.tar.gz 717144 BLAKE2B 6d09aaf4974ea022e2eece1ff6287f9fbc9e8bc3befafe6a0590521e2ba87954e94ac3ed9a38469d84e5f37cc36e2355546d6f391acb674223d47527bea4b214 SHA512 d4390d0e60f1f2a4cdaff660e2a4f13f65ae12a3e5b4db181cb34c0766874875fff068221bdf9bdcc63506fab2ebb6f74c016d10b088ace611f8876db88121be
diff --git a/dev-python/boto3/boto3-1.28.67.ebuild b/dev-python/boto3/boto3-1.28.67.ebuild
new file mode 100644
index 000000000000..a37cc38af2f3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.67.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit} \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}