summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-01 04:50:46 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-01 05:36:39 +0100
commit6841a4b392c66fb61b3786ccf166bbf7d473260b (patch)
treeb854c060ea5a4c8d1f4990595166151143418299 /dev-python/boto3
parentdev-python/botocore: Bump to 1.31.75 (diff)
downloadgentoo-6841a4b392c66fb61b3786ccf166bbf7d473260b.tar.gz
gentoo-6841a4b392c66fb61b3786ccf166bbf7d473260b.tar.bz2
gentoo-6841a4b392c66fb61b3786ccf166bbf7d473260b.zip
dev-python/boto3: Bump to 1.28.75
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.75.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c33c29fb7ecf..66236a9c3d65 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.28.63.gh.tar.gz 713769 BLAKE2B f2e300458934893bb6d2186e900c4ba9abbd
DIST boto3-1.28.68.gh.tar.gz 717553 BLAKE2B dd8ba562613456e30c0f8bfe2f3befa9601b091dacf1c19c6153ee98b81c74ed63ea1b54ce5cccfb5bcf0d67386d593276bcdd86ccb56083b54d5905042856cf SHA512 714ff8cbd52d8775bb1fc44792e21d4a93c951b9adc4ac09bacef4df2fabf0af7896edf19b6f3bd3cd9872efab1fe20f0cb07eaca51f688024a3a18515c5f371
DIST boto3-1.28.73.gh.tar.gz 720995 BLAKE2B 1ac1c85be9e095ebab3394c5b7bdc48e0ba05e97bc3e463c3fab5d6a3f46e14078f05466042cdf58250c901a42b4b80149874ee0a157b47616da8f9e65a1dbe1 SHA512 2a5f4c9e4cf86bc1b7d285d034873cedf2ada05a65ca64be3c449de8e33a351b813e4f939543cba11c183f0adb127728f20f9b769bdb2802712b47ccaa135dcb
DIST boto3-1.28.74.gh.tar.gz 721857 BLAKE2B 541e8bdab641c7d80a32a720bd848a05b73a46ae6306e0a400db46e040e626c11cdd0cdd6de15291eb2fcdfa895bf3d6a155ac86ccb17275ce58e7d18c6006d6 SHA512 b94d36e954758b9a5a11660fc8e3ae0a9c580545d9f5a2ba80ba2885c952a81708a731c92a700b251d41b583234e6185937b6d24626cec07c26982cef8c8a873
+DIST boto3-1.28.75.gh.tar.gz 722559 BLAKE2B 7d5723c5a3c66b8937718efee14a74382e40ebc23fa58761b252b5d680cfd5b0697554a9b047265fdf0813f801860334c697ccb58931096158768b4e8d3d9136 SHA512 7e91cf33c5b911373362d78676e773842d4ee7b7b92870f7cf51dbd34268b9dc054b814e77432e4931ffc63bea6c2e5350c784e4d444c946aa2991c18ce5a23f
diff --git a/dev-python/boto3/boto3-1.28.75.ebuild b/dev-python/boto3/boto3-1.28.75.ebuild
new file mode 100644
index 000000000000..a37cc38af2f3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.75.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit} \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}