summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 06:19:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 07:16:17 +0200
commit545b6aec8141b8d66382df810fa5d2fe63301f28 (patch)
tree200b3fb7eb11b92e7b55ad070cda9a245a56432d /dev-python/boto3
parentdev-python/botocore: Bump to 1.31.69 (diff)
downloadgentoo-545b6aec8141b8d66382df810fa5d2fe63301f28.tar.gz
gentoo-545b6aec8141b8d66382df810fa5d2fe63301f28.tar.bz2
gentoo-545b6aec8141b8d66382df810fa5d2fe63301f28.zip
dev-python/boto3: Bump to 1.28.69
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.69.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index def08df75028..c0ac3d3765d7 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.28.62.gh.tar.gz 712305 BLAKE2B 1d61f857143f9471a254e035cf532cab38699262b116ccc40e922005bf90ca64a33b7aa7f64df8b0641f58e250d9b6000977a50be10e5ebe93dcbf54148276b7 SHA512 f13d8f812caa650d877ecb3ae72a47ed6f93dfbfede62588266909917a1af6c8c446dbefd130d39f9a5dd156e1b9eca96a0ae084bfbadf926cdcfabfc255633c
DIST boto3-1.28.63.gh.tar.gz 713769 BLAKE2B f2e300458934893bb6d2186e900c4ba9abbd51d2ffabdbcd3026394315653e64fdc486f3ed4e33b26bef160b00e75acea875278eab03b4eeb50b5ecc94d4c0fc SHA512 782c7bb48af31638899e8bcf8fc87f67ab793fe724392be90951ece61b165f55d1df47585bd5211d7ecf3c989e5316ff9db774c8f0f357d1afc2af3ca0e49879
DIST boto3-1.28.68.gh.tar.gz 717553 BLAKE2B dd8ba562613456e30c0f8bfe2f3befa9601b091dacf1c19c6153ee98b81c74ed63ea1b54ce5cccfb5bcf0d67386d593276bcdd86ccb56083b54d5905042856cf SHA512 714ff8cbd52d8775bb1fc44792e21d4a93c951b9adc4ac09bacef4df2fabf0af7896edf19b6f3bd3cd9872efab1fe20f0cb07eaca51f688024a3a18515c5f371
+DIST boto3-1.28.69.gh.tar.gz 717978 BLAKE2B d7339e73fec81a8c8eb013b4136ab3961bb7c27cbf2b479abf12d814bb49f959dad91cc091b5ceabc01de9205b732b7df6c7fb7c37dfacc72a7d862f3e54a3f7 SHA512 2f6fa2192115367f8a899fe16308365509f543146c00be4e04c2aa323a188dedfe3e531b8d2a8b80fe9a143d101039a8a34babf5c3b1073f306f7946a45ec976
diff --git a/dev-python/boto3/boto3-1.28.69.ebuild b/dev-python/boto3/boto3-1.28.69.ebuild
new file mode 100644
index 000000000000..a37cc38af2f3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.69.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit} \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}