summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Seifert <m.seifert@digitalernachschub.de>2021-10-23 10:09:29 +0200
committerSam James <sam@gentoo.org>2021-10-24 04:16:32 +0000
commit34b38a28e105c929c69979baf79e5c00adca7a3b (patch)
tree51fccda5b7ae1165d9be86a91925f3d5a5ee1629 /dev-python/argon2-cffi
parentsci-libs/gsl: Stabilize 2.7 sparc, #804795 (diff)
downloadgentoo-34b38a28e105c929c69979baf79e5c00adca7a3b.tar.gz
gentoo-34b38a28e105c929c69979baf79e5c00adca7a3b.tar.bz2
gentoo-34b38a28e105c929c69979baf79e5c00adca7a3b.zip
dev-python/argon2-cffi: Added missing doc dependency and bumped to 21.1.0-r1
Masked USE=doc on architectures where dev-python/furo has no keyword. Closes: https://bugs.gentoo.org/816786 Signed-off-by: Michael Seifert <m.seifert@digitalernachschub.de> Closes: https://github.com/gentoo/gentoo/pull/22679 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/argon2-cffi')
-rw-r--r--dev-python/argon2-cffi/argon2-cffi-21.1.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/argon2-cffi/argon2-cffi-21.1.0-r1.ebuild b/dev-python/argon2-cffi/argon2-cffi-21.1.0-r1.ebuild
new file mode 100644
index 000000000000..fd43e943d18e
--- /dev/null
+++ b/dev-python/argon2-cffi/argon2-cffi-21.1.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="CFFI bindings to the Argon2 password hashing library"
+HOMEPAGE="https://github.com/hynek/argon2-cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ app-crypt/argon2:=
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst FAQ.rst README.rst )
+
+distutils_enable_sphinx docs \
+ dev-python/furo
+distutils_enable_tests pytest
+
+export ARGON2_CFFI_USE_SYSTEM=1