summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-05 07:20:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-05 07:54:35 +0200
commit09ff50a9e30dd3ee870e4e00274607fe3fecc04f (patch)
tree6747316bc88c19466d0eb5114025b98c2714b07e /dev-python/antlr4-python3-runtime
parentdev-python/pytz: Bump to 2023.3_p1 (diff)
downloadgentoo-09ff50a9e30dd3ee870e4e00274607fe3fecc04f.tar.gz
gentoo-09ff50a9e30dd3ee870e4e00274607fe3fecc04f.tar.bz2
gentoo-09ff50a9e30dd3ee870e4e00274607fe3fecc04f.zip
dev-python/antlr4-python3-runtime: Bump to 4.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/antlr4-python3-runtime')
-rw-r--r--dev-python/antlr4-python3-runtime/Manifest1
-rw-r--r--dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/antlr4-python3-runtime/Manifest b/dev-python/antlr4-python3-runtime/Manifest
index 888d9b78d3da..954b26703cb1 100644
--- a/dev-python/antlr4-python3-runtime/Manifest
+++ b/dev-python/antlr4-python3-runtime/Manifest
@@ -1 +1,2 @@
DIST antlr4-4.13.0.gh.tar.gz 4317288 BLAKE2B 7971b12a3d3fe50f50b9888a4de9cb7fdc28140c95a29fe00538a48da3434ec1c38643e7a1eb19457e0363b7e57747f5597081af59f653f7108f26f6515d8f35 SHA512 947ecca28712aa4dd98d7b7e0753e91881e55642f7951ca65a576b94db87440767a1b93d08e82db69ad527ee28bf89f0b2f9c0aaa604a999a7e48c163764ee12
+DIST antlr4-4.13.1.gh.tar.gz 4164054 BLAKE2B a51b91ef93bd4b540a382f8d4eb2bcd1a2e47a29ab20a601a2fdc6ea3d17f9acb62a4bda1a9383ba1d40853a2346f68fe846d700c3f8ae6c9a0f940ad8c660be SHA512 79ac3cdfc8f2368c647d06aec85d87507629a75527205ff2cbf7d9802989b0c6e6a8fac76148ad101f539c9ef922e431e22ba489f899f847ccc3d3d889bb2b70
diff --git a/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.1.ebuild b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.1.ebuild
new file mode 100644
index 000000000000..31dcc7c87016
--- /dev/null
+++ b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=antlr4-${PV}
+DESCRIPTION="Python 3 runtime for ANTLR"
+HOMEPAGE="
+ https://www.antlr.org/
+ https://github.com/antlr/antlr4/
+ https://pypi.org/project/antlr4-python3-runtime/
+"
+SRC_URI="
+ https://github.com/antlr/antlr4/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/runtime/Python3"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" tests/run.py -v || die "Tests failed with ${EPYTHON}"
+}