summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-04 14:45:59 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-04 15:12:17 +0100
commitcb0e642e8759fe22ede6cbd5e140750646650441 (patch)
tree17d4589f48ff7403b6bdf2105636968d416744aa /dev-python/agate-excel
parentdev-python/agate: Bump to 1.7.0 (diff)
downloadgentoo-cb0e642e8759fe22ede6cbd5e140750646650441.tar.gz
gentoo-cb0e642e8759fe22ede6cbd5e140750646650441.tar.bz2
gentoo-cb0e642e8759fe22ede6cbd5e140750646650441.zip
dev-python/agate-excel: PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/agate-excel')
-rw-r--r--dev-python/agate-excel/agate-excel-0.2.5-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/agate-excel/agate-excel-0.2.5-r2.ebuild b/dev-python/agate-excel/agate-excel-0.2.5-r2.ebuild
new file mode 100644
index 000000000000..c2ad9069e18c
--- /dev/null
+++ b/dev-python/agate-excel/agate-excel-0.2.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds read support for Excel files (xls and xlsx) to agate"
+HOMEPAGE="
+ https://github.com/wireservice/agate-excel/
+ https://pypi.org/project/agate-excel/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/agate-1.5.0[${PYTHON_USEDEP}]
+ dev-python/olefile[${PYTHON_USEDEP}]
+ >=dev-python/openpyxl-2.3.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/xlrd-0.9.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest