summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/PyECLib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/PyECLib')
-rw-r--r--dev-python/PyECLib/Manifest1
-rw-r--r--dev-python/PyECLib/PyECLib-1.0.7.ebuild22
-rw-r--r--dev-python/PyECLib/files/1.0.7-erasurecode_locations.patch11
-rw-r--r--dev-python/PyECLib/metadata.xml15
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/PyECLib/Manifest b/dev-python/PyECLib/Manifest
new file mode 100644
index 000000000000..5dc5ef6d5578
--- /dev/null
+++ b/dev-python/PyECLib/Manifest
@@ -0,0 +1 @@
+DIST PyECLib-1.0.7.tar.gz 8376329 SHA256 f2136f187900fe3b84c75fea671c9bcb3d4d4a6307e44d9f960ed8296ce52dc3 SHA512 8f1bbf6bd0c8ceb62862337fd204e497e5826e01c8b7532bd68485b2203e755144d0ac6b7ee9aa59fb290e8c9ee5fa3bd865203dbbdbf471e0112d10c3ea8720 WHIRLPOOL 62839fe028fc5a5d96005f337425773254d1fb287d4e2d02010ca9e1fb3df6e79f7a7fc4e03797d854b8965c24665dd93010623cf7bae8a5612b1c2e50513e80
diff --git a/dev-python/PyECLib/PyECLib-1.0.7.ebuild b/dev-python/PyECLib/PyECLib-1.0.7.ebuild
new file mode 100644
index 000000000000..7e2428fc6764
--- /dev/null
+++ b/dev-python/PyECLib/PyECLib-1.0.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Messaging API for RPC and notifications over a number of different messaging transports"
+HOMEPAGE="https://pypi.python.org/pypi/PyECLib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/liberasurecode"
+
+PATCHES=( "${FILESDIR}/1.0.7-erasurecode_locations.patch" )
diff --git a/dev-python/PyECLib/files/1.0.7-erasurecode_locations.patch b/dev-python/PyECLib/files/1.0.7-erasurecode_locations.patch
new file mode 100644
index 000000000000..9f12a56cf19a
--- /dev/null
+++ b/dev-python/PyECLib/files/1.0.7-erasurecode_locations.patch
@@ -0,0 +1,11 @@
+--- setup.py 2015-04-15 18:13:08.000000000 -0500
++++ setup.py.new 2015-08-04 20:36:06.236656803 -0500
+@@ -66,7 +66,7 @@
+ default_include_paths = [default_python_incdir,
+ '/usr/local/include', '/usr/local/include/jerasure',
+ '/usr/include', 'src/c/pyeclib_c',
+- '/usr/local/include']
++ '/usr/include/liberasurecode', '/usr/local/include']
+
+ libflags = ''
+ includeflags = ''
diff --git a/dev-python/PyECLib/metadata.xml b/dev-python/PyECLib/metadata.xml
new file mode 100644
index 000000000000..c981fdb3e31f
--- /dev/null
+++ b/dev-python/PyECLib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ This library provides a simple Python interface for implementing erasure codes. To obtain the best possible performance, the underlying erasure code algorithms are written in C.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">PyECLib</remote-id>
+ </upstream>
+</pkgmetadata>