summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-29 05:30:14 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-29 05:36:50 +0100
commitdcb2eeea7a5cbb0b34fc0c53c1dd74863d94127e (patch)
tree7fb582a00e99ff7b044e37e3eed68742b02687d6 /dev-python/Nuitka
parentapp-admin/awscli: Bump to 1.32.73 (diff)
downloadgentoo-dcb2eeea7a5cbb0b34fc0c53c1dd74863d94127e.tar.gz
gentoo-dcb2eeea7a5cbb0b34fc0c53c1dd74863d94127e.tar.bz2
gentoo-dcb2eeea7a5cbb0b34fc0c53c1dd74863d94127e.zip
dev-python/Nuitka: Bump to 2.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-2.1.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 6e3dd232b9d8..0f5e095c0c5a 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-2.1.2.tar.gz 3633406 BLAKE2B adf3cc4bcf1c5d72223f5709dc0a4cbb6e24a59c36483acf6b6da6949025f9bb37b010dbcf79178f886c2cc8c907c45d47d5b615666b824413463fee08a88a21 SHA512 04403622bb4071afca1357e9b5603914f9a984af8b4f4af06be0bd476956b41e497a718746b9bcf66576490ae7b4bd75c5b7e6ff5f7240d1c66a6c5396d06d32
DIST Nuitka-2.1.3.tar.gz 3636137 BLAKE2B 3842acc34820576e395abbe0c2a76cfffa97f1b2bd28f1d2559a2f89c1fcd14a0edab77e4e05783eb7b8de6daac6328799b124c1fddd5af3e133eaf26799e5c8 SHA512 295e20b844a4ee019fea003bc4455c1751cf39ae3104568914e2a39a3665e024b149df64940f84f5717c4c456212ca87f62c5d1e8064d88e1ddfbefa3943b487
+DIST Nuitka-2.1.4.tar.gz 3636629 BLAKE2B b5a3f3067e12029c9bd1e9ae60d1c6c6370d929ad38a8092f0150078440c50ed925768e132ac18542eaa3ab4f2198f6773cb79cf51dee68b3dff9bec26cb37ad SHA512 bd7e164bed8943c5ea3e7ff30069ef7b9308cd47486fded22cf1f2a37274f0f6274b2af0cb84ca188e961745b93ab085f937e228ce193a1fff953537d5143205
diff --git a/dev-python/Nuitka/Nuitka-2.1.4.ebuild b/dev-python/Nuitka/Nuitka-2.1.4.ebuild
new file mode 100644
index 000000000000..123acd66de1f
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-2.1.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" dev-util/patchelf
+}