summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-29 06:07:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-29 06:13:30 +0200
commit7c24158d1d2c7ce3480cb62f8180d68b2124586b (patch)
treead7f9325f691d5147530b81f1b9ca4c04e20732c /dev-python/Faker
parentdev-python/autopep8: Bump to 2.1.2 (diff)
downloadgentoo-7c24158d1d2c7ce3480cb62f8180d68b2124586b.tar.gz
gentoo-7c24158d1d2c7ce3480cb62f8180d68b2124586b.tar.bz2
gentoo-7c24158d1d2c7ce3480cb62f8180d68b2124586b.zip
dev-python/Faker: Bump to 25.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-25.3.0.ebuild40
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-25.3.0.ebuild b/dev-python/Faker/Faker-25.3.0.ebuild
new file mode 100644
index 000000000000..f7ca8ee10616
--- /dev/null
+++ b/dev-python/Faker/Faker-25.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+}
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 7eeab17fcf7f..8af7753edf83 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1 +1,2 @@
DIST Faker-25.2.0.tar.gz 1760547 BLAKE2B cba47dd21caaabef23212d38b856c67d9d68c6478f44269ed0da7df4aa06cd313caef1d8072572c2b680172e6a6313548228cbd446e397b6e29fd3e5317bc707 SHA512 bec0a516944f36a4714bcb9b8d46dbd4ab3fb3feb6d4818fd28e9d22d0cfd1621845f669940d41365ec423398ef58714e18de5ae537ce7524cf27018ab088c8f
+DIST Faker-25.3.0.tar.gz 1760396 BLAKE2B 46e12f80a84385b4bb50e19a26fe436be1ee846f87309869bc624ec45c15550f33e733d70d9e87c493521020c4e16cddb6f17f2bbc36b6d8072829f582f0beed SHA512 d4b3a762d22b9947ebae254d07abc7e0c3511d9277439075fe876371f1c25dbcbe5a08729e33925c98ec86ef3b5f3321b5a3ac3802784bb42f8296fe9a09eb30