summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-11-29 16:16:39 +0000
committerSam James <sam@gentoo.org>2024-12-01 11:25:56 +0000
commit85f526a904f361e68f418a903b09af80e0e621f6 (patch)
tree519898340810108fb4531273c5e3217657ae1bae /dev-php
parentgames-emulation/nestopia-jg: fix C++ odr warnings (diff)
downloadgentoo-85f526a904f361e68f418a903b09af80e0e621f6.tar.gz
gentoo-85f526a904f361e68f418a903b09af80e0e621f6.tar.bz2
gentoo-85f526a904f361e68f418a903b09af80e0e621f6.zip
dev-php/pecl-amqp: add 2.1.2
Closes: https://bugs.gentoo.org/933651 Bug: https://bugs.gentoo.org/943650 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39522 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-amqp/Manifest1
-rw-r--r--dev-php/pecl-amqp/pecl-amqp-2.1.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/pecl-amqp/Manifest b/dev-php/pecl-amqp/Manifest
index 792277fe5c9f..2783a716b8ca 100644
--- a/dev-php/pecl-amqp/Manifest
+++ b/dev-php/pecl-amqp/Manifest
@@ -1 +1,2 @@
DIST amqp-1.11.0.tgz 108493 BLAKE2B 5d06ee39f9fef03652ee668695378e30df8c01c57c4ce724b2934bf0754d2a2a9c5998d599a34b2782b5395a5a4bcb69925f6d578ff160dfe7407e7916d468ba SHA512 0f0220fc2f1f9109640e096ab38a4bb06b2569a336b83f527d18dae2b8c21efaf383dade807ee5bb3dbf4447bc3548c15f38ac18155762fe7920ef8939bc0321
+DIST amqp-2.1.2.tgz 118454 BLAKE2B 595e321b36c1189e0abfbb1711b822ba954a132d576ee973ce29f3a7f9dcbbe771b7452dd9101aa95bcde8a1c4b6ea0cba2512e06dd42e23e9c466a81ef43e71 SHA512 27ccbf27e04d4008dfcabcf576e44ee6bfa88e6cf0161fe4dccc1af594d2d8ec01e7c1b16e39f6f1ce2fddbc29ccc19113f2f56182d78cf727b4bb2767fefb54
diff --git a/dev-php/pecl-amqp/pecl-amqp-2.1.2.ebuild b/dev-php/pecl-amqp/pecl-amqp-2.1.2.ebuild
new file mode 100644
index 000000000000..2b137df21ed3
--- /dev/null
+++ b/dev-php/pecl-amqp/pecl-amqp-2.1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_PHP="php8-2 php8-3"
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP Bindings for AMQP 0-9-1 compatible brokers"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Tests require running rabbitmq-server on localhost which requires epmd
+# which only accepts /var/run/epmd.pid as pidfile.
+RESTRICT="test"
+
+RDEPEND=">=net-libs/rabbitmq-c-0.13.0:=[ssl(-)]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"