summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-06-07 15:09:56 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-06-07 16:08:02 +0200
commit727453126c8efff726bfb4dabf32cb3a98f85918 (patch)
treed2f68e13248ddda7ce225164d0657ed0a34c125c /dev-php
parentdev-php/pecl-raphf: add PHP 7.3 support (diff)
downloadgentoo-727453126c8efff726bfb4dabf32cb3a98f85918.tar.gz
gentoo-727453126c8efff726bfb4dabf32cb3a98f85918.tar.bz2
gentoo-727453126c8efff726bfb4dabf32cb3a98f85918.zip
dev-php/pecl-crack: add PHP 7.3 support
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-crack/pecl-crack-0.4-r7.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-php/pecl-crack/pecl-crack-0.4-r7.ebuild b/dev-php/pecl-crack/pecl-crack-0.4-r7.ebuild
index 08d5e3ea1c16..841669f34fda 100644
--- a/dev-php/pecl-crack/pecl-crack-0.4-r7.ebuild
+++ b/dev-php/pecl-crack/pecl-crack-0.4-r7.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="7"
PHP_EXT_NAME="crack"
PHP_EXT_INI="yes"
@@ -9,7 +9,7 @@ PHP_EXT_ZENDEXT="no"
PHP_EXT_EXTRA_ECONF=""
DOCS=( EXPERIMENTAL )
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
inherit php-ext-pecl-r3
@@ -19,8 +19,10 @@ DESCRIPTION="PHP interface to the cracklib libraries"
LICENSE="PHP-3 CRACKLIB"
SLOT="0"
IUSE=""
+
# Patch for http://pecl.php.net/bugs/bug.php?id=5765
-PATCHES=( "${FILESDIR}/fix-php-5-4-support.patch"
-"${FILESDIR}/fix-pecl-bug-5765.patch"
-"${FILESDIR}/${PV}-php7.patch"
+PATCHES=(
+ "${FILESDIR}/fix-php-5-4-support.patch"
+ "${FILESDIR}/fix-pecl-bug-5765.patch"
+ "${FILESDIR}/${PV}-php7.patch"
)