summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/phing
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/phing')
-rw-r--r--dev-php/phing/Manifest2
-rw-r--r--dev-php/phing/metadata.xml5
-rw-r--r--dev-php/phing/phing-2.10.1.ebuild46
-rw-r--r--dev-php/phing/phing-2.8.2.ebuild46
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-php/phing/Manifest b/dev-php/phing/Manifest
new file mode 100644
index 000000000000..c347acba66aa
--- /dev/null
+++ b/dev-php/phing/Manifest
@@ -0,0 +1,2 @@
+DIST phing-2.10.1.phar 851181 SHA256 7df436757a0a9427e1983af4847abfbadc92a6b4535b1e60b69bacfb139da6f8 SHA512 026b08945f189be30b29268aa9a8fb889975addd385e7087cb3f1e1bd2b5a01cabddff47fa52d197bbc520c4d5ad6e47edaa5446300e0baeebff24165f7c4246 WHIRLPOOL ae60318f2551510ca40b011f538849928256d2e081d6d910f14f519db2838edf0925256df2a33dee4d37797d7b670e8761e3a93340fe1d44ad951b841fa08492
+DIST phing-2.8.2.phar 813699 SHA256 253ab59905ecb60b0be2d95bb4e222f0a71b9368fc24f022b64b9b23fc60198e SHA512 55304054a2c90787a29958143276be58bcfc8165db0594360853531dec3c9efaf3330ca1d217007fe0f700adb19b6cf98755f3f2b7dc4e1cd1bbfe7ee338b56f WHIRLPOOL afd5f76dd253691d725380532dabbdc69500bc290d1cb11fb343ed848f4f6f8417fb69ee49fe2f9455a6d202787fb6dd2834b788f8899e3640379286b2775323
diff --git a/dev-php/phing/metadata.xml b/dev-php/phing/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/phing/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/phing/phing-2.10.1.ebuild b/dev-php/phing/phing-2.10.1.ebuild
new file mode 100644
index 000000000000..ecc1044d8500
--- /dev/null
+++ b/dev-php/phing/phing-2.10.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="PHP project build system based on Apache Ant"
+HOMEPAGE="http://www.phing.info/"
+SRC_URI="http://www.phing.info/get/phing-${PV}.phar"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+minimal"
+
+DEPEND=""
+RDEPEND="!minimal? ( dev-php/phpDocumentor
+ dev-php/PHP_CodeCoverage
+ >=dev-php/PEAR-HTTP_Request2-2.1.1
+ >=dev-php/PEAR-PEAR_PackageFileManager-1.5.2
+ >=dev-php/PEAR-VersionControl_SVN-0.3.0_alpha1
+ >=dev-php/phpmd-1.1.0
+ >=dev-php/phpunit-4.0
+ >=dev-php/xdebug-2.0.5
+ >=dev-php/simpletest-1.0.1_beta2 )
+ dev-lang/php:*[cli,phar,xml,xslt]
+ "
+
+S=${WORKDIR}
+
+src_unpack() { :; }
+
+src_install() {
+ insinto /usr/share/php/phing
+ insopts -m755
+ newins "${DISTDIR}/${P}.phar" phing.phar
+ dosym /usr/share/php/phing/phing.phar /usr/bin/phing
+}
+
+pkg_postinst() {
+ if use minimal; then
+ elog "You have enabled the minimal USE flag. If you want to use features"
+ elog "from xdebug, phpunit, simpletest and more, disable the"
+ elog "USE flag or emerge the packages manually"
+ fi
+}
diff --git a/dev-php/phing/phing-2.8.2.ebuild b/dev-php/phing/phing-2.8.2.ebuild
new file mode 100644
index 000000000000..45da1f517348
--- /dev/null
+++ b/dev-php/phing/phing-2.8.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="PHP project build system based on Apache Ant"
+HOMEPAGE="http://www.phing.info/"
+SRC_URI="http://www.phing.info/get/phing-${PV}.phar"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+minimal"
+
+DEPEND=""
+RDEPEND="!minimal? ( dev-php/phpDocumentor
+ dev-php/PHP_CodeCoverage
+ >=dev-php/PEAR-HTTP_Request2-2.1.1
+ >=dev-php/PEAR-PEAR_PackageFileManager-1.5.2
+ >=dev-php/PEAR-VersionControl_SVN-0.3.0_alpha1
+ >=dev-php/phpmd-1.1.0
+ >=dev-php/phpunit-4.0
+ >=dev-php/xdebug-2.0.5
+ >=dev-php/simpletest-1.0.1_beta2 )
+ dev-lang/php[phar,xml,xslt]
+ "
+
+S=${WORKDIR}
+
+src_unpack() { :; }
+
+src_install() {
+ insinto /usr/share/php/phing
+ insopts -m755
+ newins "${DISTDIR}/${P}.phar" phing.phar
+ dosym /usr/share/php/phing/phing.phar /usr/bin/phing
+}
+
+pkg_postinst() {
+ if use minimal; then
+ elog "You have enabled the minimal USE flag. If you want to use features"
+ elog "from xdebug, phpunit, simpletest and more, disable the"
+ elog "USE flag or emerge the packages manually"
+ fi
+}