summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-02-11 20:27:14 -0500
committerBrian Evans <grknight@gentoo.org>2017-02-11 20:27:14 -0500
commit8acac1023a44085ad5883ac7b20c47bc5ccbd098 (patch)
tree5a96a2e6034b284cbf31ad00ca5374a5cdf7b8b4 /dev-php/pecl-mongodb
parentx11-misc/albert: version bump 0.9.3 (diff)
downloadgentoo-8acac1023a44085ad5883ac7b20c47bc5ccbd098.tar.gz
gentoo-8acac1023a44085ad5883ac7b20c47bc5ccbd098.tar.bz2
gentoo-8acac1023a44085ad5883ac7b20c47bc5ccbd098.zip
dev-php/pecl-mongodb: Version bump and include PHP 7.1 wrt bug 609018
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/pecl-mongodb')
-rw-r--r--dev-php/pecl-mongodb/Manifest1
-rw-r--r--dev-php/pecl-mongodb/pecl-mongodb-1.1.10.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/pecl-mongodb/Manifest b/dev-php/pecl-mongodb/Manifest
index 58aa60294337..49826a8127cc 100644
--- a/dev-php/pecl-mongodb/Manifest
+++ b/dev-php/pecl-mongodb/Manifest
@@ -1 +1,2 @@
+DIST mongodb-1.1.10.tgz 661847 SHA256 1c779c50b5ebe25acf399d899d8df727d794588ee1ef3d2039ee0bbd7f287f18 SHA512 36096ceaec04aa4670b7d7d8e0b23edf786bab7184718642869455f5ddc6562eeb1a56f524550bea7f0dfe3aa44b12a25c32b20744ee8c843aacb1f03458ebd0 WHIRLPOOL 83670e7ec2928964deb4889f0edbb344e6594fb29133b4e56375fa26933d00227ee5a7a53ebda779e3dca9cc4ae6bc25bd6cc47cc192eeca473c4a87a32618cd
DIST mongodb-1.1.8.tgz 806900 SHA256 b93ae7dc9bd270823965f8903c9acf47fe3a0ba7a630d08e8173ff091d593ae0 SHA512 1026b4081cd1c35f1f6fee6332c21dbe739320236377c0ed21b8d64447a9ba26464a919ceb9c16b332a64f12b834700472d6cbfb336d09d841c97ca0b402bf17 WHIRLPOOL 9cd2ce71f06684a3717e1cc016684d54b877f31166cbd194dc595dc878ebdda0320210ed090ac85d2aef40c94299499feedcf52faa712cec1c14aef1ae1f25d5
diff --git a/dev-php/pecl-mongodb/pecl-mongodb-1.1.10.ebuild b/dev-php/pecl-mongodb/pecl-mongodb-1.1.10.ebuild
new file mode 100644
index 000000000000..46582ddff862
--- /dev/null
+++ b/dev-php/pecl-mongodb/pecl-mongodb-1.1.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="mongodb"
+USE_PHP="php5-6 php7-0 php7-1"
+DOCS=( README.md )
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="MongoDB database driver for PHP"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl pcre sasl"
+
+RDEPEND="
+ php_targets_php5-6? ( dev-lang/php:5.6[json,ssl,zlib] )
+ php_targets_php7-0? ( dev-lang/php:7.0[json,ssl,zlib] )
+ php_targets_php7-1? ( dev-lang/php:7.1[json,ssl,zlib] )
+ >=dev-libs/libbson-1.3.3
+ >=dev-libs/mongo-c-driver-1.3.3[sasl?,ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ pcre? ( dev-libs/libpcre )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+# pkgconfig needed if system libraries are used for bson and libmongoc
+DEPEND="${RDEPEND} virtual/pkgconfig"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-mongodb
+ --with-libbson
+ --with-libmongoc
+ --with-pcre-dir=$(usex pcre)
+ --with-mongodb-sasl=$(usex sasl)
+ )
+ php-ext-source-r3_src_configure
+}