summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-29 00:47:56 +0000
committerSam James <sam@gentoo.org>2024-02-29 00:47:56 +0000
commitd5413c49a093b77dd397f5343936c9926599fde7 (patch)
tree284d3fee3d6d3eba56566f9bfa0f5f970f3df6d5 /dev-perl
parentdev-libs/libev: filter LTO, no-SA (diff)
downloadgentoo-d5413c49a093b77dd397f5343936c9926599fde7.tar.gz
gentoo-d5413c49a093b77dd397f5343936c9926599fde7.tar.bz2
gentoo-d5413c49a093b77dd397f5343936c9926599fde7.zip
dev-perl/EV: filter LTO, no-SA
Broken quite badly via bundled liebv, no upstream bug tracker for libev AFAICT. And broken in many bundled copies all over the place (which are modified...) Closes: https://bugs.gentoo.org/856109 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/EV/EV-4.330.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-perl/EV/EV-4.330.0.ebuild b/dev-perl/EV/EV-4.330.0.ebuild
index ec997f6507ff..374a2b8ab945 100644
--- a/dev-perl/EV/EV-4.330.0.ebuild
+++ b/dev-perl/EV/EV-4.330.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=MLEHMANN
DIST_VERSION=4.33
-inherit perl-module
+inherit flag-o-matic perl-module
DESCRIPTION="Perl interface to libev, a high performance full-featured event loop"
LICENSE=" || ( Artistic GPL-1+ ) || ( BSD-2 GPL-2+ )"
@@ -21,6 +21,10 @@ BDEPEND="${RDEPEND}
dev-perl/Canary-Stability
"
src_compile() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
mymake=(
"OPTIMIZE=${CFLAGS}"
)