summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-18 04:07:32 +0100
committerSam James <sam@gentoo.org>2023-06-18 04:12:10 +0100
commit7af9b93c6f1825865dab99512ef2b4a91e64ddd0 (patch)
tree10a5bb7c5f7c262d7e30a959c69f5c40be6e17d4 /dev-perl/Text-CSV/Text-CSV-2.20.0.ebuild
parentdev-perl/Text-CSV_XS: add 1.500.0 (diff)
downloadgentoo-7af9b93c6f1825865dab99512ef2b4a91e64ddd0.tar.gz
gentoo-7af9b93c6f1825865dab99512ef2b4a91e64ddd0.tar.bz2
gentoo-7af9b93c6f1825865dab99512ef2b4a91e64ddd0.zip
dev-perl/Text-CSV: add 2.20.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Text-CSV/Text-CSV-2.20.0.ebuild')
-rw-r--r--dev-perl/Text-CSV/Text-CSV-2.20.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Text-CSV/Text-CSV-2.20.0.ebuild b/dev-perl/Text-CSV/Text-CSV-2.20.0.ebuild
new file mode 100644
index 000000000000..a2422cfd3ff6
--- /dev/null
+++ b/dev-perl/Text-CSV/Text-CSV-2.20.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ISHIGAKI
+DIST_VERSION=2.02
+inherit perl-module
+
+DESCRIPTION="Manipulate comma-separated value strings"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="+xs"
+
+RDEPEND="
+ xs? ( >=dev-perl/Text-CSV_XS-1.480.0 )
+ virtual/perl-IO
+"
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/00_pod.t
+ perl-module_src_test
+}