summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-05-02 16:55:01 +1100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-05-02 17:28:44 +1100
commit8a9f20051a89f82cc008fd441651109f04cae698 (patch)
tree868f1443897e70050ddfab288c5e942d5bc0f239 /dev-perl/Test-Kit/Test-Kit-2.160.0.ebuild
parentmedia-video/yle-dl: stabilize 20240429 for ALLARCHES (diff)
downloadgentoo-8a9f20051a89f82cc008fd441651109f04cae698.tar.gz
gentoo-8a9f20051a89f82cc008fd441651109f04cae698.tar.bz2
gentoo-8a9f20051a89f82cc008fd441651109f04cae698.zip
dev-perl/Test-Kit: add 2.160.0
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Test-Kit/Test-Kit-2.160.0.ebuild')
-rw-r--r--dev-perl/Test-Kit/Test-Kit-2.160.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Test-Kit/Test-Kit-2.160.0.ebuild b/dev-perl/Test-Kit/Test-Kit-2.160.0.ebuild
new file mode 100644
index 000000000000..251c0fe003c9
--- /dev/null
+++ b/dev-perl/Test-Kit/Test-Kit-2.160.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=KAORU
+DIST_VERSION=2.16
+inherit perl-module
+
+DESCRIPTION="Build custom test packages with only the features you want"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86 ~x64-macos"
+
+RDEPEND="
+ virtual/perl-Exporter
+ dev-perl/Hook-LexWrap
+ dev-perl/Import-Into
+ dev-perl/Module-Runtime
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Sub-Delete
+ virtual/perl-Test-Simple
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Output
+ >=virtual/perl-Test-Simple-0.920.0
+ dev-perl/Test-Warn
+ )
+"
+PERL_RM_FILES=(
+ "t/author-pod-syntax.t"
+ "t/release-cpan-changes.t"
+)