summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-08-03 10:41:41 +1200
committerKent Fredric <kentnl@gentoo.org>2016-08-03 10:43:43 +1200
commit4126f7aa2ec132ce4237e4f631ccd067349913ba (patch)
tree36ad8742a96521f5a725bf468f8b651df4959368 /dev-perl/Test-Deep
parentdev-java/icedtea: Remove old 3.0.1 (diff)
downloadgentoo-4126f7aa2ec132ce4237e4f631ccd067349913ba.tar.gz
gentoo-4126f7aa2ec132ce4237e4f631ccd067349913ba.tar.bz2
gentoo-4126f7aa2ec132ce4237e4f631ccd067349913ba.zip
dev-perl/Test-Deep: Weaken dependency on dev-perl/Test-Tester
Without this fix, Test-Deep effectively needs perl-5.22 stabilized in order to satisfy Test-Tester from Perl-5.22 However, satisfying Test-Tester from a mechanism other than Perl-5.22 confuses portages dependency resolver, and confuses portage to not be able to upgrade perl, and not being able to upgrade perl means perl can't be stabilized, invoking a stabilization-needs-stabilization bug. Hence, the choice here optimises for assuming stabilization will happen/has happened, and removes any dependency on Test::Tester, assuming portage will eventually provide it for you. And just to be sure, we use perl before the test phase executes to determine if Test::Tester was /actually/ installed and then only run tests if it was. This means before stabilization, some people *might* install this and not have tests run, but everyone *will* get tests working after stabilization, as opposed to the opposite occurring and stabilization being blocked. Bug: https://bugs.gentoo.org/584238 Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Test-Deep')
-rw-r--r--dev-perl/Test-Deep/Test-Deep-1.120.0.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-perl/Test-Deep/Test-Deep-1.120.0.ebuild b/dev-perl/Test-Deep/Test-Deep-1.120.0.ebuild
index 18203ba23795..85759f86efa5 100644
--- a/dev-perl/Test-Deep/Test-Deep-1.120.0.ebuild
+++ b/dev-perl/Test-Deep/Test-Deep-1.120.0.ebuild
@@ -22,9 +22,16 @@ DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
>=virtual/perl-Test-Simple-0.880.0
- || (
- >=virtual/perl-Test-Simple-1.1.10
- ( <virtual/perl-Test-Simple-1.1.10 >=dev-perl/Test-Tester-0.40.0 )
- )
)
"
+
+src_test() {
+ # Bug 584238 Avoidance
+ if perl -e 'exit ( eval { require Test::Tester; Test::Tester->VERSION(0.04); 1 } ? 0 : 1 )'; then
+ perl-module_src_test
+ else
+ einfo "Test phase skipped: Test::Tester required for tests"
+ einfo "Please upgrade to >=dev-lang/perl-5.22.0 or >=virtual/perl-Test-Simple-1.1.10"
+ einfo "if you want this tested"
+ fi
+}