summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-22 02:43:15 +0100
committerSam James <sam@gentoo.org>2024-05-22 02:44:03 +0100
commit1a03690c377ae3b4d8472eb247b104ddfb8d8764 (patch)
tree41a0cbaa0f9ef717399726b9c85448c2639d669d /dev-perl/Net-LibIDN2/Net-LibIDN2-1.20.0-r1.ebuild
parentperl-module.eclass: don't set 'ccflags' for Module::Build (diff)
downloadgentoo-1a03690c377ae3b4d8472eb247b104ddfb8d8764.tar.gz
gentoo-1a03690c377ae3b4d8472eb247b104ddfb8d8764.tar.bz2
gentoo-1a03690c377ae3b4d8472eb247b104ddfb8d8764.zip
dev-perl/Net-LibIDN2: use eclass phase functions
As I noted in the bug: > dev-perl/Net-LibIDN2 doesn't use the Module::Build support in the eclass, > so we should fix that. This means it doesn't get all the flag variables, > but it ends up not being the problem here. It's also just clutter to unnecessarily (and not as comprehensively) do the same thing the eclass does, so clean it up. Bug: https://bugs.gentoo.org/932176 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Net-LibIDN2/Net-LibIDN2-1.20.0-r1.ebuild')
-rw-r--r--dev-perl/Net-LibIDN2/Net-LibIDN2-1.20.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/Net-LibIDN2/Net-LibIDN2-1.20.0-r1.ebuild b/dev-perl/Net-LibIDN2/Net-LibIDN2-1.20.0-r1.ebuild
new file mode 100644
index 000000000000..4653fa41e669
--- /dev/null
+++ b/dev-perl/Net-LibIDN2/Net-LibIDN2-1.20.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=THOR
+DIST_VERSION=1.02
+inherit perl-module
+
+DESCRIPTION="Perl bindings for GNU Libidn2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="net-dns/libidn2:="
+DEPEND="net-dns/libidn2:="
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ virtual/perl-ExtUtils-CBuilder
+ virtual/perl-ExtUtils-ParseXS
+ dev-perl/Module-Build
+ test? (
+ >=virtual/perl-Test-Simple-0.10.0
+ )
+"