summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-21 23:19:22 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-21 23:39:25 +0100
commitd4b6273a7404bc13344f91a98345fe1c74148146 (patch)
treef7eebdfa215568afeed64915dbf243203a1de674 /dev-perl/Crypt-SSLeay
parentdev-ruby/cocaine: Remove old (diff)
downloadgentoo-d4b6273a7404bc13344f91a98345fe1c74148146.tar.gz
gentoo-d4b6273a7404bc13344f91a98345fe1c74148146.tar.bz2
gentoo-d4b6273a7404bc13344f91a98345fe1c74148146.zip
dev-perl/Crypt-SSLeay: Add version compatible with libressl-2.3 (no SSL2, no SSL3)
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Crypt-SSLeay')
-rw-r--r--dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild40
-rw-r--r--dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch40
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild
new file mode 100644
index 000000000000..a1b178abc688
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=NANIS
+DIST_VERSION=0.72
+inherit perl-module
+
+DESCRIPTION="OpenSSL support for LWP"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( >=dev-libs/openssl-0.9.7c:0= )
+ libressl? ( dev-libs/libressl:0= )
+ virtual/perl-MIME-Base64
+"
+
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=virtual/perl-ExtUtils-CBuilder-0.280.205
+ virtual/perl-Getopt-Long
+ >=dev-perl/Path-Class-0.260.0
+ >=dev-perl/Try-Tiny-0.190.0
+ test? (
+ >=virtual/perl-Test-Simple-0.190.0
+ )
+"
+# PDEPEND: circular dependencies bug #144761
+PDEPEND="
+ dev-perl/libwww-perl
+ >=dev-perl/LWP-Protocol-https-6.20.0
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.720.0-no-ssl3.patch )
diff --git a/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch b/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch
new file mode 100644
index 000000000000..72febbfff7e9
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/files/Crypt-SSLeay-0.720.0-no-ssl3.patch
@@ -0,0 +1,40 @@
+--- a/SSLeay.xs 2014-04-24 07:36:24.000000000 +0000
++++ b/SSLeay.xs 2015-12-27 13:39:05.695422091 +0000
+@@ -45,13 +45,6 @@
+ }
+ #endif
+
+-
+-#if SSLEAY_VERSION_NUMBER >= 0x0900
+-#define CRYPT_SSL_CLIENT_METHOD SSLv3_client_method()
+-#else
+-#define CRYPT_SSL_CLIENT_METHOD SSLv2_client_method()
+-#endif
+-
+ static void InfoCallback(const SSL *s,int where,int ret)
+ {
+ const char *str;
+@@ -145,22 +138,7 @@
+ RAND_seed(buf, CRYPT_SSLEAY_RAND_BUFSIZE);
+ }
+
+- if(ssl_version == 23) {
+- ctx = SSL_CTX_new(SSLv23_client_method());
+- }
+- else if(ssl_version == 3) {
+- ctx = SSL_CTX_new(SSLv3_client_method());
+- }
+- else {
+-#ifndef OPENSSL_NO_SSL2
+- /* v2 is the default */
+- ctx = SSL_CTX_new(SSLv2_client_method());
+-#else
+- /* v3 is the default */
+- ctx = SSL_CTX_new(SSLv3_client_method());
+-#endif
+- }
+-
++ ctx = SSL_CTX_new(SSLv23_client_method());
+ SSL_CTX_set_options(ctx,SSL_OP_ALL|0);
+ SSL_CTX_set_default_verify_paths(ctx);
+ SSL_CTX_set_verify(ctx, SSL_VERIFY_NONE, NULL);