summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois-Xavier Carton <fx.carton91@gmail.com>2020-11-27 18:41:45 +0100
committerSam James <sam@gentoo.org>2021-01-04 17:27:04 +0000
commit581237f305695944e3869f7baba9d64f7f08e561 (patch)
tree97d70a755cc982b0fbbceaccd08ad6d0d65ebd83 /dev-ml/yojson
parentdev-ml/biniou: drop old (diff)
downloadgentoo-581237f305695944e3869f7baba9d64f7f08e561.tar.gz
gentoo-581237f305695944e3869f7baba9d64f7f08e561.tar.bz2
gentoo-581237f305695944e3869f7baba9d64f7f08e561.zip
dev-ml/yojson: bump to 1.7.0
Signed-off-by: François-Xavier Carton <fx.carton91@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18436 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/yojson')
-rw-r--r--dev-ml/yojson/Manifest1
-rw-r--r--dev-ml/yojson/metadata.xml9
-rw-r--r--dev-ml/yojson/yojson-1.7.0.ebuild32
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-ml/yojson/Manifest b/dev-ml/yojson/Manifest
index 1e6fd2ae0045..040e490a07d3 100644
--- a/dev-ml/yojson/Manifest
+++ b/dev-ml/yojson/Manifest
@@ -1 +1,2 @@
DIST yojson-1.4.0.tar.gz 26197 BLAKE2B c7d1a9d47f448995b31cd7631f64dec29e65b1f141854092bfe186a58c28b96c5c7f246f7e4ab4563dfcd84776904d4af77bbcbdc4e149229fbde339bd92df9f SHA512 dc019ecf0387299282c3df9a548456d2529993241911a83acb14f2361ed14886e5ebebe415773b6bc718cb0b12a25529184f3b5b62c71b42960fbd62e1c63bf6
+DIST yojson-1.7.0.tar.gz 29704 BLAKE2B edbd7f66d69a85880fc8ee9bb25a993744a310887024f7af63665ba8f5067f1b9383ec4d6dd5f4ca3376d698665a8f605c078f7597ddd4e71857c1a20143c2e5 SHA512 25eedb64e4bf7c7e8d5a5a115812cd502540afbdeb7c947da3a14e5968aa0a7db8ab402425662571d8935b9cd6a19796ce81dd80a65dc614f156626c60e7036e
diff --git a/dev-ml/yojson/metadata.xml b/dev-ml/yojson/metadata.xml
index 96ead416877d..a6f01f34da1b 100644
--- a/dev-ml/yojson/metadata.xml
+++ b/dev-ml/yojson/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <name>François-Xavier Carton</name>
+ <email>fx.carton91@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">mjambon/yojson</remote-id>
</upstream>
diff --git a/dev-ml/yojson/yojson-1.7.0.ebuild b/dev-ml/yojson/yojson-1.7.0.ebuild
new file mode 100644
index 000000000000..fbfcfb4f3d5c
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/yojson"
+SRC_URI="https://github.com/ocaml-community/yojson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.02.3:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ >=dev-ml/biniou-1.2:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ >=dev-ml/cppo-1.6.1
+"
+
+src_install() {
+ dune_src_install
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}