summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-07-11 18:57:30 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-07-11 18:57:30 +0200
commit7de0dee784ad2d9e89534a177cde761f9bca7806 (patch)
treedb93ae2663e50b7f4303de04b31e09d9a0492636 /dev-ml/stdune/stdune-3.9.1.ebuild
parentdev-ml/dyn: add 3.9.1 (diff)
downloadgentoo-7de0dee784ad2d9e89534a177cde761f9bca7806.tar.gz
gentoo-7de0dee784ad2d9e89534a177cde761f9bca7806.tar.bz2
gentoo-7de0dee784ad2d9e89534a177cde761f9bca7806.zip
dev-ml/stdune: add 3.9.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/stdune/stdune-3.9.1.ebuild')
-rw-r--r--dev-ml/stdune/stdune-3.9.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/stdune/stdune-3.9.1.ebuild b/dev-ml/stdune/stdune-3.9.1.ebuild
new file mode 100644
index 000000000000..8d82be573c81
--- /dev/null
+++ b/dev-ml/stdune/stdune-3.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Dune's unstable standard library"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3.5"
+DEPEND="
+ dev-ml/pp:=[ocamlopt?]
+ ~dev-ml/dyn-${PV}:=[ocamlopt?]
+ ~dev-ml/ordering-${PV}:=[ocamlopt?]
+ >=dev-ml/csexp-1.5:=[ocamlopt?]
+ !<dev-ml/dune-private-libs-3
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}