summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHank Leininger <hlein@korelogic.com>2021-06-01 10:29:43 -0600
committerSam James <sam@gentoo.org>2021-06-06 23:55:18 +0000
commit52d438422968d43ce090534d9e80b89e4f905754 (patch)
treee28167441fa4e4a41bd1f155f968b488b50f60ef /dev-ml/opam-installer/opam-installer-2.0.8-r3.ebuild
parentdev-ml/opam-state: patch for dose3-6.x compat (diff)
downloadgentoo-52d438422968d43ce090534d9e80b89e4f905754.tar.gz
gentoo-52d438422968d43ce090534d9e80b89e4f905754.tar.bz2
gentoo-52d438422968d43ce090534d9e80b89e4f905754.zip
dev-ml/opam-installer: patch for dose3-6.x compat
Lifted from Debian, see https://bugs.debian.org/982733 Signed-off-by: Hank Leininger <hlein@korelogic.com> Closes: https://bugs.gentoo.org/788265 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Closes: https://github.com/gentoo/gentoo/pull/20686 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/opam-installer/opam-installer-2.0.8-r3.ebuild')
-rw-r--r--dev-ml/opam-installer/opam-installer-2.0.8-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/opam-installer-2.0.8-r3.ebuild b/dev-ml/opam-installer/opam-installer-2.0.8-r3.ebuild
new file mode 100644
index 000000000000..7bd84a692fe7
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.0.8-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+inherit opam
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+# Cherry-picked from https://deb.debian.org/debian/pool/main/o/opam/opam_2.0.8-1.debian.tar.xz
+PATCHES=( "${FILESDIR}/debian-Port-to-Dose3-6.0.1.patch" )
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3
+ dev-ml/cmdliner:=
+ ~dev-ml/opam-format-${PV}
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}
+
+src_compile() {
+ sed -e 's/DUNE = .*$/DUNE = /' -i Makefile.config
+ #passing -jX to the dune build leads to errors
+ #see: https://github.com/ocaml/opam/issues/3585
+ emake DUNE_PROMOTE_ARG="" -j1
+}