summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-14 10:06:44 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-05 22:16:59 +0200
commit361d6a2500fc99c28bea27a69fce3b583ce30d02 (patch)
tree5876ea0c3570f578498b70876bd6b1a2815e9569 /dev-ml/ocamlnet
parentdev-ml/oasis: Replace STRIP_MASK with RESTRICT="strip" (diff)
downloadgentoo-361d6a2500fc99c28bea27a69fce3b583ce30d02.tar.gz
gentoo-361d6a2500fc99c28bea27a69fce3b583ce30d02.tar.bz2
gentoo-361d6a2500fc99c28bea27a69fce3b583ce30d02.zip
dev-ml/ocamlnet: Replace STRIP_MASK with RESTRICT=strip
Closes: https://bugs.gentoo.org/651440 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.2.ebuild9
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.3.ebuild9
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild9
3 files changed, 6 insertions, 21 deletions
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.2.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.2.ebuild
index 6d89e100f0ec..a16de2e6b12f 100644
--- a/dev-ml/ocamlnet/ocamlnet-4.1.2.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-4.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -14,7 +14,7 @@ LICENSE="ZLIB GPL-2+"
SLOT="0/${PV}"
KEYWORDS="amd64 ppc x86 x86-fbsd"
IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
-RESTRICT="installsources"
+RESTRICT="installsources strip"
# the auth-dh compile flag has been disabled as well, since it depends on
# ocaml-cryptgps, which is not available.
@@ -74,8 +74,3 @@ src_compile() {
emake -j1 opt
fi
}
-
-src_install() {
- export STRIP_MASK="*/bin/*"
- findlib_src_install
-}
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.3.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.3.ebuild
index 1460d03f5cc4..d6e4d239beb6 100644
--- a/dev-ml/ocamlnet/ocamlnet-4.1.3.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-4.1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -14,7 +14,7 @@ LICENSE="ZLIB GPL-2+"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
-RESTRICT="installsources"
+RESTRICT="installsources strip"
# the auth-dh compile flag has been disabled as well, since it depends on
# ocaml-cryptgps, which is not available.
@@ -70,8 +70,3 @@ src_compile() {
emake -j1 opt
fi
}
-
-src_install() {
- export STRIP_MASK="*/bin/*"
- findlib_src_install
-}
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild
index 1460d03f5cc4..d6e4d239beb6 100644
--- a/dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -14,7 +14,7 @@ LICENSE="ZLIB GPL-2+"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
-RESTRICT="installsources"
+RESTRICT="installsources strip"
# the auth-dh compile flag has been disabled as well, since it depends on
# ocaml-cryptgps, which is not available.
@@ -70,8 +70,3 @@ src_compile() {
emake -j1 opt
fi
}
-
-src_install() {
- export STRIP_MASK="*/bin/*"
- findlib_src_install
-}