summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-30 14:47:24 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-30 14:47:24 +0100
commitad1dbb66da4dd9f3093a0767bec747fb8d9ba8d4 (patch)
treee931cb19414fae4fcdbd993c46dab0cc96476f2e /dev-ml/ocaml-containers
parentdev-libs/cryptlib: cleanups (diff)
downloadgentoo-ad1dbb66da4dd9f3093a0767bec747fb8d9ba8d4.tar.gz
gentoo-ad1dbb66da4dd9f3093a0767bec747fb8d9ba8d4.tar.bz2
gentoo-ad1dbb66da4dd9f3093a0767bec747fb8d9ba8d4.zip
dev-ml/ocaml-containers: bump to 0.22.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/ocaml-containers')
-rw-r--r--dev-ml/ocaml-containers/Manifest1
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-0.22.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/Manifest b/dev-ml/ocaml-containers/Manifest
index 5834b2874b34..77b4f9f57f61 100644
--- a/dev-ml/ocaml-containers/Manifest
+++ b/dev-ml/ocaml-containers/Manifest
@@ -1 +1,2 @@
+DIST ocaml-containers-0.22.1.tar.gz 429672 SHA256 2ef64e8ed93211dfd4f8cd594943db3cde81ee0400b17703d8a7993128634622 SHA512 9294d43485cd17998f9d0c758ee0ffdc187ea78f1f456c0b06a57a9401c6de529e9e68bad12908b2b0da5f22fca64835acb90f3dfd6ee3403bb7c3c301cd6821 WHIRLPOOL 67844578447b321439223b5f560258cb5d5417135dfdbfdaf2fa10e104beb764e9ca6ae0ab774864c974d928e75aa5aedc7e90ea5659d910f33349a7ec4b568b
DIST ocaml-containers-0.22.tar.gz 429678 SHA256 883e64a6b2275355086521a67d5fe0e436bbf79f54c8fb068a05ab3cf3408e98 SHA512 1454f8bcd11d02a9efd2fe223e2db591d2e1d66df6877af920b4d8a2cc3a2c6b34b0979069015565618700dfb4a74d6a8f2d8cd8f9fc6fa7888331320ea41c46 WHIRLPOOL f5993d629fe2a803b1284cd5794f3345060215cf16bb97347dd2173b7015735ddcd43b98c3b5ccf365d372ffedf77892e862fbc276b24468699a95492dc784e7
diff --git a/dev-ml/ocaml-containers/ocaml-containers-0.22.1.ebuild b/dev-ml/ocaml-containers/ocaml-containers-0.22.1.ebuild
new file mode 100644
index 000000000000..ad9387aa679c
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-0.22.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/result:=
+ >=dev-ml/sequence-0.9:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo
+ test? ( dev-ml/iTeML )"
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}