summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-23 09:18:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-23 10:15:49 +0100
commit6f3b8add5ba409c7b9eab96b68d5dbff54c45b7e (patch)
treebad45eff157c3d105aa4e9aae9cc558a8498ff5c /dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild
parentdev-ml/logs: Initial import. Ebuild by me. (diff)
downloadgentoo-6f3b8add5ba409c7b9eab96b68d5dbff54c45b7e.tar.gz
gentoo-6f3b8add5ba409c7b9eab96b68d5dbff54c45b7e.tar.bz2
gentoo-6f3b8add5ba409c7b9eab96b68d5dbff54c45b7e.zip
dev-ml/ocaml-conduit: Initial import. Ebuild by me.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild')
-rw-r--r--dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild b/dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild
new file mode 100644
index 000000000000..6402be1841e6
--- /dev/null
+++ b/dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Dereference URIs into communication channels for Async or Lwt"
+HOMEPAGE="https://github.com/mirage/ocaml-conduit"
+SRC_URI="https://github.com/mirage/ocaml-conduit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sexplib:=
+ dev-ml/stringext:=
+ dev-ml/ocaml-uri:=
+ dev-ml/logs:=
+ dev-ml/ocaml-cstruct:=
+ dev-ml/ocaml-ipaddr:=
+
+ dev-ml/lwt:=
+ dev-ml/async:=
+ dev-ml/ocaml-dns:=
+ dev-ml/ocaml-ssl:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/ppx_driver
+ dev-ml/ppx_optcomp
+ dev-ml/ppx_sexp_conv
+"
+
+DOCS=( TODO.md README.md CHANGES )
+
+src_install() {
+ findlib_src_preinst
+ default
+}