summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-19 01:20:25 +0000
committerSam James <sam@gentoo.org>2022-11-19 01:34:44 +0000
commit6607bc47bc8b5a12283fe21c539cc9687adf2741 (patch)
tree70f2ea74506bbb7ee9265c7bb6c85ac097624616 /dev-ml/labltk
parentdev-ml/labltk: add github upstream metadata (diff)
downloadgentoo-6607bc47bc8b5a12283fe21c539cc9687adf2741.tar.gz
gentoo-6607bc47bc8b5a12283fe21c539cc9687adf2741.tar.bz2
gentoo-6607bc47bc8b5a12283fe21c539cc9687adf2741.zip
dev-ml/labltk: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/881841 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/labltk')
-rw-r--r--dev-ml/labltk/files/labltk-8.06.7-configure.patch27
-rw-r--r--dev-ml/labltk/files/labltk-8.06.9-configure-clang16.patch50
-rw-r--r--dev-ml/labltk/labltk-8.06.10-r1.ebuild (renamed from dev-ml/labltk/labltk-8.06.10.ebuild)1
-rw-r--r--dev-ml/labltk/labltk-8.06.11-r1.ebuild (renamed from dev-ml/labltk/labltk-8.06.11.ebuild)1
-rw-r--r--dev-ml/labltk/labltk-8.06.12-r1.ebuild (renamed from dev-ml/labltk/labltk-8.06.12.ebuild)1
-rw-r--r--dev-ml/labltk/labltk-8.06.7-r1.ebuild (renamed from dev-ml/labltk/labltk-8.06.7.ebuild)2
-rw-r--r--dev-ml/labltk/labltk-8.06.9-r1.ebuild (renamed from dev-ml/labltk/labltk-8.06.9.ebuild)1
7 files changed, 83 insertions, 0 deletions
diff --git a/dev-ml/labltk/files/labltk-8.06.7-configure.patch b/dev-ml/labltk/files/labltk-8.06.7-configure.patch
new file mode 100644
index 000000000000..320f92f7ce45
--- /dev/null
+++ b/dev-ml/labltk/files/labltk-8.06.7-configure.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/881841
+https://github.com/garrigue/labltk/commit/be8c977d320ed40cacb322658d4ceba5e583b3a6
+
+From be8c977d320ed40cacb322658d4ceba5e583b3a6 Mon Sep 17 00:00:00 2001
+From: Jacques Garrigue <garrigue@math.nagoya-u.ac.jp>
+Date: Mon, 24 Aug 2020 11:27:34 +0900
+Subject: [PATCH] Fix config/auto-aux/hasgot for clang 12
+
+--- a/config/auto-aux/hasgot
++++ b/config/auto-aux/hasgot
+@@ -30,7 +30,8 @@ while : ; do
+ shift
+ done
+
+-(echo "main() {"
++(for f in $*; do echo "int $f();"; done
++ echo "int main() {"
+ for f in $*; do echo " $f();"; done
+ echo "}") >> hasgot.c
+
+--- a/config/auto-aux/hasgot.c
++++ /dev/null
+@@ -1,3 +0,0 @@
+-main() {
+- Tk_SetGrid();
+-}
+
diff --git a/dev-ml/labltk/files/labltk-8.06.9-configure-clang16.patch b/dev-ml/labltk/files/labltk-8.06.9-configure-clang16.patch
new file mode 100644
index 000000000000..bc7e04175f7f
--- /dev/null
+++ b/dev-ml/labltk/files/labltk-8.06.9-configure-clang16.patch
@@ -0,0 +1,50 @@
+https://bugs.gentoo.org/881841
+https://github.com/garrigue/labltk/pull/17
+
+From e1e850972c4190686a040574b91d61948cc559b5 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 19 Nov 2022 01:14:25 +0000
+Subject: [PATCH] config: Fix -Wimplicit-int, -Wstrict-prototypes (Clang 16)
+
+Followup to be8c977d320ed40cacb322658d4ceba5e583b3a6.
+
+Clang 16 makes -Wimplicit-int error by default.
+
+Unfortunately, this can lead to misconfiguration or miscompilation of software as configure
+tests may then return the wrong result.
+
+We also fix -Wstrict-prototypes while here as it's easy to do and it prepares
+us for C23.
+
+For more information, see LWN.net [0] or LLVM's Discourse [1], the Gentoo wiki [2],
+or the (new) c-std-porting mailing list [3].
+
+[0] https://lwn.net/Articles/913505/
+[1] https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213
+[2] https://wiki.gentoo.org/wiki/Modern_C_porting
+[3] hosted at lists.linux.dev.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/config/auto-aux/hasgot
++++ b/config/auto-aux/hasgot
+@@ -31,7 +31,7 @@ while : ; do
+ done
+
+ (for f in $*; do echo "int $f();"; done
+- echo "int main() {"
++ echo "int main(void) {"
+ for f in $*; do echo " $f();"; done
+ echo "}") >> hasgot.c
+
+--- a/config/auto-aux/tclversion.c
++++ b/config/auto-aux/tclversion.c
+@@ -18,7 +18,7 @@
+ #include <tcl.h>
+ #include <tk.h>
+
+-main ()
++int main (void)
+ {
+ puts(TCL_VERSION);
+ }
+
diff --git a/dev-ml/labltk/labltk-8.06.10.ebuild b/dev-ml/labltk/labltk-8.06.10-r1.ebuild
index 0e2d1e982325..ba2aeaa5b347 100644
--- a/dev-ml/labltk/labltk-8.06.10.ebuild
+++ b/dev-ml/labltk/labltk-8.06.10-r1.ebuild
@@ -24,6 +24,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/findlib.patch"
+ "${FILESDIR}"/${PN}-8.06.9-configure-clang16.patch
"${WORKDIR}"/${P}-warnings.patch
)
diff --git a/dev-ml/labltk/labltk-8.06.11.ebuild b/dev-ml/labltk/labltk-8.06.11-r1.ebuild
index 150ac43273e3..d3936002790d 100644
--- a/dev-ml/labltk/labltk-8.06.11.ebuild
+++ b/dev-ml/labltk/labltk-8.06.11-r1.ebuild
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/findlib.patch"
+ "${FILESDIR}"/${PN}-8.06.9-configure-clang16.patch
)
src_prepare() {
diff --git a/dev-ml/labltk/labltk-8.06.12.ebuild b/dev-ml/labltk/labltk-8.06.12-r1.ebuild
index 3042cc64e298..fe10ce5dc4e6 100644
--- a/dev-ml/labltk/labltk-8.06.12.ebuild
+++ b/dev-ml/labltk/labltk-8.06.12-r1.ebuild
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/findlib.patch"
+ "${FILESDIR}"/${PN}-8.06.9-configure-clang16.patch
)
src_prepare() {
diff --git a/dev-ml/labltk/labltk-8.06.7.ebuild b/dev-ml/labltk/labltk-8.06.7-r1.ebuild
index 637bdd00956e..4acab0317733 100644
--- a/dev-ml/labltk/labltk-8.06.7.ebuild
+++ b/dev-ml/labltk/labltk-8.06.7-r1.ebuild
@@ -22,6 +22,8 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/findlib.patch"
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${PN}-8.06.9-configure-clang16.patch
)
src_prepare() {
diff --git a/dev-ml/labltk/labltk-8.06.9.ebuild b/dev-ml/labltk/labltk-8.06.9-r1.ebuild
index 7bce5317f51d..aad779f428a8 100644
--- a/dev-ml/labltk/labltk-8.06.9.ebuild
+++ b/dev-ml/labltk/labltk-8.06.9-r1.ebuild
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/findlib.patch"
+ "${FILESDIR}"/${PN}-8.06.9-configure-clang16.patch
)
src_prepare() {