summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-10-20 19:26:04 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-10-20 19:48:38 +0200
commit3141cef092ab95a3185cd5392617261336f820f9 (patch)
treef36225f90baa374cbfd9d1a8d285042c847d9cda /dev-ml/iostream/iostream-0.3.ebuild
parentdev-ml/hmap: new package, add 0.8.1 (diff)
downloadgentoo-3141cef092ab95a3185cd5392617261336f820f9.tar.gz
gentoo-3141cef092ab95a3185cd5392617261336f820f9.tar.bz2
gentoo-3141cef092ab95a3185cd5392617261336f820f9.zip
dev-ml/iostream: new package, add 0.3
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/iostream/iostream-0.3.ebuild')
-rw-r--r--dev-ml/iostream/iostream-0.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ml/iostream/iostream-0.3.ebuild b/dev-ml/iostream/iostream-0.3.ebuild
new file mode 100644
index 000000000000..62cda1ba3dd1
--- /dev/null
+++ b/dev-ml/iostream/iostream-0.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DUNE_PKG_NAME="iostream iostream-camlzip"
+inherit dune
+
+DESCRIPTION="Generic, composable IO input and output streams"
+HOMEPAGE="https://github.com/c-cube/ocaml-iostream"
+SRC_URI="https://github.com/c-cube/ocaml-${PN}/releases/download/v${PV}/${P}.tbz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/camlzip:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"