summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-29 21:41:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-29 22:03:28 +0200
commit9062517f3f24048bfa823d5c3f41330acf17ef82 (patch)
treead8a388c19727a29346c95ee70267b55f8780f9f /dev-lisp
parentdev-scheme/chez: bump to 9.6.0 (diff)
downloadgentoo-9062517f3f24048bfa823d5c3f41330acf17ef82.tar.gz
gentoo-9062517f3f24048bfa823d5c3f41330acf17ef82.tar.bz2
gentoo-9062517f3f24048bfa823d5c3f41330acf17ef82.zip
dev-lisp/abcl: bump to 1.9.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/abcl/Manifest1
-rw-r--r--dev-lisp/abcl/abcl-1.9.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-lisp/abcl/Manifest b/dev-lisp/abcl/Manifest
index 93a72cd31d84..aabcf4c762a4 100644
--- a/dev-lisp/abcl/Manifest
+++ b/dev-lisp/abcl/Manifest
@@ -1 +1,2 @@
DIST abcl-src-1.9.1.tar.gz 2499007 BLAKE2B 4448a42caa1c283291691eaf5f045504d4e9549b50929ca414094523ea4ce8180f769073b7c8be3358fb3976974c7a86e1b42f850d1ff7f5ab0955731aeabc8b SHA512 52ee6b82d99f8667610afdc4af2065cd868aa6661f6d4d1af1dbae979128529d5b2e0523caf7b3c6a5460ba55636c7aca4b145fabb6b4748b5ac046742fc8960
+DIST abcl-src-1.9.2.tar.gz 2477992 BLAKE2B b69610ee11e59dc0c408905b3a5f57d23872d80466a2f3aa4828048cb016de371a6f90dace612cb1a0fd71919cd611b4d506b22491c54b3435c80ec27f3642ed SHA512 1b758b26be5dbe00fb75aef0ffca6cdfbbb7982a545c63b6378dbd3d22bed76e15628ee099c5728c3600d67fb74def249195060cc1af1486f6d52fcdb9ce245a
diff --git a/dev-lisp/abcl/abcl-1.9.2.ebuild b/dev-lisp/abcl/abcl-1.9.2.ebuild
new file mode 100644
index 000000000000..db16ee80cdf0
--- /dev/null
+++ b/dev-lisp/abcl/abcl-1.9.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Armed Bear Common Lisp is a Common Lisp implementation for the JVM"
+HOMEPAGE="https://abcl.org"
+SRC_URI="https://abcl.org/releases/${PV}/abcl-src-${PV}.tar.gz"
+S="${WORKDIR}/abcl-src-${PV}"
+
+LICENSE="GPL-2-with-classpath-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*"
+
+DOCS=( README )
+
+src_compile() {
+ eant abcl.compile
+ eant abcl.jar || die "Can't make ABCL jar archive"
+}
+
+src_install() {
+ java-pkg_dojar dist/abcl.jar dist/abcl-contrib.jar
+ java-pkg_dolauncher ${PN} --java_args "-server -Xrs" --main org.armedbear.lisp.Main
+
+ einstalldocs
+}