summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-02-21 11:46:31 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-02-22 09:20:36 +0100
commit3d3ccc55b979694cdb4434ba6a663ebe4c40a29d (patch)
tree1bb90a660e28f941efa3420a7d0e6de3dbead9ed /dev-lisp
parentsci-libs/caffe2: drop 1.12.0-r1, 1.12.1, 1.13.0-r1 (diff)
downloadgentoo-3d3ccc55b979694cdb4434ba6a663ebe4c40a29d.tar.gz
gentoo-3d3ccc55b979694cdb4434ba6a663ebe4c40a29d.tar.bz2
gentoo-3d3ccc55b979694cdb4434ba6a663ebe4c40a29d.zip
dev-lisp/abcl: add 1.9.1
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/29697 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/abcl/Manifest1
-rw-r--r--dev-lisp/abcl/abcl-1.9.1.ebuild30
-rw-r--r--dev-lisp/abcl/metadata.xml12
3 files changed, 39 insertions, 4 deletions
diff --git a/dev-lisp/abcl/Manifest b/dev-lisp/abcl/Manifest
index e3c4c5d796f6..44113c4ed81e 100644
--- a/dev-lisp/abcl/Manifest
+++ b/dev-lisp/abcl/Manifest
@@ -1 +1,2 @@
DIST abcl-src-1.9.0.tar.gz 2470791 BLAKE2B e6c79a7f9dc94fe978c81f0752774b54b850c3019eb40a66cb043e6463ae6aa80b8e09d628847017335cf077029f6548be40394adf06a8549609b5bb7cb26dd1 SHA512 d061565a4e89fd11238118fccf72ea212b9bc87c708f89f13e8e9564d984ee405a189b93fd904ecae7b7f6663ca130b5c7ab774f7f9fd31282708c639e3ef9f6
+DIST abcl-src-1.9.1.tar.gz 2499007 BLAKE2B 4448a42caa1c283291691eaf5f045504d4e9549b50929ca414094523ea4ce8180f769073b7c8be3358fb3976974c7a86e1b42f850d1ff7f5ab0955731aeabc8b SHA512 52ee6b82d99f8667610afdc4af2065cd868aa6661f6d4d1af1dbae979128529d5b2e0523caf7b3c6a5460ba55636c7aca4b145fabb6b4748b5ac046742fc8960
diff --git a/dev-lisp/abcl/abcl-1.9.1.ebuild b/dev-lisp/abcl/abcl-1.9.1.ebuild
new file mode 100644
index 000000000000..437eb6796fc9
--- /dev/null
+++ b/dev-lisp/abcl/abcl-1.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Armed Bear Common Lisp is a Common Lisp implementation for the JVM"
+HOMEPAGE="https://abcl.org"
+SRC_URI="https://abcl.org/releases/${PV}/abcl-src-${PV}.tar.gz"
+
+LICENSE="GPL-2-with-classpath-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/abcl-src-${PV}"
+
+src_compile() {
+ eant abcl.compile
+ eant abcl.jar || die "Can't make ABCL jar archive"
+}
+
+src_install() {
+ java-pkg_dojar dist/abcl.jar dist/abcl-contrib.jar
+ java-pkg_dolauncher ${PN} --java_args "-server -Xrs" --main org.armedbear.lisp.Main
+ dodoc README
+}
diff --git a/dev-lisp/abcl/metadata.xml b/dev-lisp/abcl/metadata.xml
index 49330cd5e11a..66fa0ac73e12 100644
--- a/dev-lisp/abcl/metadata.xml
+++ b/dev-lisp/abcl/metadata.xml
@@ -2,15 +2,19 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
- <email>common-lisp@gentoo.org</email>
- <name>Gentoo Common Lisp Project</name>
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
</maintainer>
<maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
+ <email>java@gentoo.org</email>
+ <name>Java</name>
</maintainer>
<longdescription>
Armed Bear Common Lisp (ABCL) is an implementation of ANSI Common
Lisp that runs in a Java virtual machine.
</longdescription>
+ <upstream>
+ <bugs-to>https://abcl.org/trac/report/1</bugs-to>
+ <remote-id type="github">armedbear/abcl</remote-id>
+ </upstream>
</pkgmetadata>