summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-09-12 17:58:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-12 21:27:30 +0200
commitecc3166ea62603f442bd4b7e2274c36552961b0c (patch)
treeafd39bd0952037073954b82d0ae5007b784b7f4c /dev-libs
parentapp-office/merkuro: 24.08.1 version bump (diff)
downloadgentoo-ecc3166ea62603f442bd4b7e2274c36552961b0c.tar.gz
gentoo-ecc3166ea62603f442bd4b7e2274c36552961b0c.tar.bz2
gentoo-ecc3166ea62603f442bd4b7e2274c36552961b0c.zip
dev-libs/kopeninghours: 24.08.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-24.08.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 604ef47b0389..911a2ea0c230 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1 +1,2 @@
DIST kopeninghours-24.08.0.tar.xz 74612 BLAKE2B 66bf4bbc405e53746679ddb00aa3ab481e43ca041658bcf62875057881d079fc698563bcad49cd4c0a03f31fa9a3b8c027b3ff69d1fb6052cc73d2bffc539538 SHA512 a5f71f6c95d9a4ef9c78148ef960893240707a73faa917510a52fe821789cf88cc7bd46af43d9d46f83e36129e13ab4de42fa080198e36c49e6a84830ce39f9a
+DIST kopeninghours-24.08.1.tar.xz 74616 BLAKE2B de96e19675b4c29eb388b3a120e97c1435b1fa7652b7b86d8adcaca8a5afb167481fd444a429a03f6fd285bf4623e5cb3af5e3952788300918a9281d5d2a091c SHA512 b219bf9c7d3a302112e84d9022f9ff37c7153870099972d7ad2c5154c391462ef7397df0bc09cb956a5e6cc2ee6d22ed53fc84d9efb07c03a8df17db5e9b8594
diff --git a/dev-libs/kopeninghours/kopeninghours-24.08.1.ebuild b/dev-libs/kopeninghours/kopeninghours-24.08.1.ebuild
new file mode 100644
index 000000000000..1084d8654d19
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-24.08.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+PYTHON_COMPAT=( python3_{10..12} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:6
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kholidays-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}