summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-13 05:31:30 +0000
committerSam James <sam@gentoo.org>2023-11-13 06:06:53 +0000
commitc4fa72f65cc6718ff3f584647759020788a211e6 (patch)
tree0b6b59c4adcae124d7b90d53747b08a8e9ee86e1 /dev-libs
parentdev-python/keyring: Bump to 24.3.0 (diff)
downloadgentoo-c4fa72f65cc6718ff3f584647759020788a211e6.tar.gz
gentoo-c4fa72f65cc6718ff3f584647759020788a211e6.tar.bz2
gentoo-c4fa72f65cc6718ff3f584647759020788a211e6.zip
dev-libs/icu: backport test-only fix
No runtime changes, fix is to the test itself. Closes: https://bugs.gentoo.org/914887 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icu/files/icu-73.2-fix-TestHebrewCalendarInTemporalLeapYear-test.patch31
-rw-r--r--dev-libs/icu/icu-73.2.ebuild1
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/icu/files/icu-73.2-fix-TestHebrewCalendarInTemporalLeapYear-test.patch b/dev-libs/icu/files/icu-73.2-fix-TestHebrewCalendarInTemporalLeapYear-test.patch
new file mode 100644
index 000000000000..df4dd0793837
--- /dev/null
+++ b/dev-libs/icu/files/icu-73.2-fix-TestHebrewCalendarInTemporalLeapYear-test.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/914887
+https://github.com/unicode-org/icu/commit/f3b869cbb0b9ced42d7ca4e24626a868a14ddcfc
+
+From f3b869cbb0b9ced42d7ca4e24626a868a14ddcfc Mon Sep 17 00:00:00 2001
+From: Frank Tang <ftang@chromium.org>
+Date: Mon, 18 Sep 2023 20:20:42 -0700
+Subject: [PATCH] ICU-22512 Fix broken TestHebrewCalendarInTemporalLeapYear
+
+Fix broken test mistakenly landed in
+https://github.com/unicode-org/icu/pull/2274
+
+Some important steps were missed in the last landing.
+--- a/test/intltest/caltest.cpp
++++ b/test/intltest/caltest.cpp
+@@ -4028,6 +4028,7 @@ void CalendarTest::TestHebrewCalendarInTemporalLeapYear() {
+ for (gc.set(startYear, UCAL_JANUARY, 1);
+ gc.get(UCAL_YEAR, status) <= stopYear;
+ gc.add(UCAL_DATE, incrementDays, status)) {
++ cal->setTime(gc.getTime(status), status);
+ if (failure(status, "add/get/set/getTime/setTime incorrect")) return;
+
+ int32_t cal_year = cal->get(UCAL_EXTENDED_YEAR, status);
+@@ -4036,6 +4037,7 @@ void CalendarTest::TestHebrewCalendarInTemporalLeapYear() {
+ leapTest->set(UCAL_MONTH, 0);
+ leapTest->set(UCAL_DATE, 1);
+ // If 10 months after TISHRI is TAMUZ, then it is a leap year.
++ leapTest->add(UCAL_MONTH, 10, status);
+ hasLeapMonth = leapTest->get(UCAL_MONTH, status) == icu::HebrewCalendar::TAMUZ;
+ yearForHasLeapMonth = cal_year;
+ }
+
diff --git a/dev-libs/icu/icu-73.2.ebuild b/dev-libs/icu/icu-73.2.ebuild
index 84eeae5d9534..870eed474993 100644
--- a/dev-libs/icu/icu-73.2.ebuild
+++ b/dev-libs/icu/icu-73.2.ebuild
@@ -42,6 +42,7 @@ PATCHES=(
"${FILESDIR}/${PN}-65.1-remove-bashisms.patch"
"${FILESDIR}/${PN}-64.2-darwin.patch"
"${FILESDIR}/${PN}-68.1-nonunicode.patch"
+ "${FILESDIR}/${P}-fix-TestHebrewCalendarInTemporalLeapYear-test.patch"
)
src_prepare() {